Seeking packages for Raspberry Pi 3 (stretch)

I have spent 15-20 hours trying to get various versions of Nextcloud to work in server form on a Raspberry Pi 3 running stretch, as well as a a Mac (Mojave) and other Raspberry Pi clients. I cannot enumerate all the error messages I’ve encountered along the way (for forums like this I would normally supply detailed information, but I literally don’t know where to start), but they include apache/php/sql compatibility issues, missing index files, missing status files (including one message that referred to owncloud/status.php), even a client window that mistranslated my keystrokes to the point where I had to paste information into the dialog, and finally client setup windows that reject any attempt to connect to the server that I managed to get running.

Since Nextcloud requires several other applications to work together in terms of version levels, not to mention the server and several different clients, my question is whether there are complete packages that will work for Raspberry Pi stretch (not buster - I’m not ready to upgrade an entire suite of machines), and not Docker (I have other services I’d like to run, and it carries the overhead of learning yet another package - my experience with Docker has not been good), and not an SD card image - for similar reasons.

I’ve seen promising packages that require buster: if that’s the only option, I will set this project aside for now.

You can take a look on my stretch branch

But be aware that this comes with no guarantee. It‘s only customised for my own needs and not build to be generic. The last working NC version is 15.0.x and php version is 7.0 which is out of support.

Have you seen this? Other options include setting up a LAMPS stack and installing the server package yourself (from the archive), or use the NextCloudPi image.

Thanks. Do any of these sites host packages for ARM (not Intel/AMD) architecture, which is what Raspberry Pi uses? I’m also interested in a client for an Odroid N2 (arm7).