Searching in Group Folders

Nextcloud version (eg, 20.0.5): 18.0.14 > 21.0.1
Operating system and version (eg, Ubuntu 20.04): Synology Web Station
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4
PHP version (eg, 7.4): 7.3 > 7.4

The issue you are facing:
When I open Nextcloud, I see groups that have been shared by other users as well as group folders that are accessible to me. But when I use search, it only shows search results from the shared folders and not from the group folders. Underneath it says “Search other places” with the rotating circle. How can I also search groups? Thanks for any advice.

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Open Nextcloud
  2. Search for term that matches a file name in group folder
  3. The file is not found

I have now updated to Nextcloud 21. The problem is still there.

Hi, I am just guessing because you are missing a lot of info about your server but is this maybe your issue? Files in group folders don´t get indexed in search when user/group has no sharing rights · Issue #1033 · nextcloud/groupfolders · GitHub
Apart from this there is no open issue regarding search in the groupfolders repository, afaics.

Many thanks for your response. What additional information would be important? It is the WebStation of a Synology NAS. I have now activated sharing for the admins group as a test. And after that had no effect, the group folders were also re-read in via occ groupfolders: scan. Have I generally restricted the sharing of provided content too much? The content should not be able to be shared by users. The other users should not be visible.



Looks like the search generally no longer works since the updates.


Good afternoon @Geronimo82

How are you?

So, before anything try this:
(If your httpd user is not www-data, change it (eg, apache))

1) sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --on
2) chown -R www-data:www-data /var/www/nextcloud/
3) chmod -R 770 /var/www/nextcloud/
4) sudo -u www-data php /var/www/nextcloud/occ maintenance:repair
5) sudo -u www-data php /var/www/nextcloud/occ db:add-missing-columns
6) sudo -u www-data php /var/www/nextcloud/occ db:add-missing-indices
7) sudo -u www-data php /var/www/nextcloud/occ maintenance:update:htaccess
8) sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off
9) sudo systemctl restart apache2

Also, check your php version running “php -v”, that can help a lot.

Make sure you have php-fpm installed and running.

Hope this helps, have a nice weekend.

All the best!


I have now done all of this with the correct user and the correct paths. The problem still occurs.

1 Like

I am getting a lot of these errors in apache24-error_log.

1 Like

Hello @Geronimo82

Did you change your php-fpm settings for a boost perfomance?

I recommend you to use PHP-FPM Process Caluculator to calcule your config.

After that, do this:

vim /etc/opt/remi/php74/php-fpm.d/www.conf

pm = dynamic
pm.max_children = 120
pm.start_servers = 12
pm.min_spare_servers = 6
pm.max_spare_servers = 18

I currently have this settings (4 GB RAM).


Okay mate, so if you have 4GB you can actually boost your performance with this config:

But keep in mind this will not solve you issue, is just for performance.

I’am thinking and searching what more we can try to do to resolve your issue here.

Good luck man.

1 Like

Similar errors in nginx error.log.

Even if there is no error…

Send a screenshot of your “Share Settings” please.

The file Test.txt in directory Test is my own file and not shared. The Group Folders are shared with admin group with the permission to share them as well because there may be a problem if users are not allowed to share the files shared with them. I’m testing as member of the admin group.


Apparently I was able to fix the problem with error 504 by setting the values extremely high, but I still cannot find my test folder and the test file in it (“No search results for test”). How does Nextcloud work with the search? Do you search live or do you create an index in advance? Can and should you reset this if necessary?

Okay, the error is back, but only occurs when searching for files.


I am about to give up. :slightly_frowning_face: