Quota_include_external_storage not working

Hi and greetings,

We installed Nextcloud and mounted an external CIFS-Share. Plan is to force the users to store their files
in the external share because of backup-policies and so on.

We set the user quota on 0 KB and added the following rule in de config.php

‘quota_include_external_storage’ => false,

But sadly I still get the error when uploading files to the CIFS that there is insufficient
disk space.

I’ve spend a good day searching the web and reading forums but I can’t seem to find a solution
to our problem.

Is this a by design issue or is there something I’m doing wrong?

and you checked permissions on the cifs-share?

Yes, I checked them and they are fine.
Problem isn’t in the persmissions.

As soon as I change the user quota in Nextcloud to 10 GB I can upload to the CIFS again.
As soon as I change the user quota in Nextcloud back to 0 KB I can’t upload to the CIFS.

hmpf… asked before, but no answer then: Quota_include_external_storage true and false makes no difference

There are numerous people with the same problem but I can’t seem to find an answer if
it’s a by design thing of it’s a wrong setting on my side.