Problem with collabora and nextcloud 23.0.2


When I try to open the office file with the Android client, I only get a loading circle and sometime a message that loading takes a long time.

Tested versions:

  • collabora (standalone version)
  • nextcloud 23.0.2
  • Android Client 3.19.0

Opening and editing of Office programs via Web browser works without any problems



If someone could check with the same versions and the standalone collabora server if office documents are still opening in the nextcloud android phone app i can look further.

I tried everything and i think its a bug somehow.

Works both with Firefox on Windows and Android 12 with NC client 3.19.0 using NC 23.0.2 (Apache) + Collabora (previously used successful). Both server applications run as separate docker container with different networks and docker-compose files behind one traefik proxy, everything on the physical hardware.

i dont understand this.

maybe a stupid question but could you share your config with me? i can not seem to find whats the problem. specially because webbased all is working?

The config I posted here is almost complete. traefik is easier then Nginx but there are working examples around.

As I referenced already my setup is to have plain http behind the proxy (don’t want additional complexity of TLS within application container).

the only idea I had was IPv6 but as you are confident this is not an issue… I have no idea as well. I think you have to go the long way and troubleshoot one piece after another using debug logs of the applications and reverse proxy - there must be something different…

BTW I don’t remember did you test mobile browser? For me it works less good than NC mobile client - the doc opens and edit works but all the menu items are not there (Android 12, Firefox).

Hi wwe,

Yes in mobile browser it works. im am trying to install a new nextcloud instance bare metal to see if it will work then. if this wont work i installed everything as bare metal and tested.

thanks for you help so far. i really appreciate it.


yes i found the issue.

it was a problem with the reverse proxy. i create a different redirect link that the mobile app did not liked

i am so happy i found it.

thank you for you effort!!!

1 Like

really cool you finally found the issue. Maybe you could describe the problematic setting and maybe post your working config?


Yes indeed.

Wel what is important in apache2 is that in the nextcloud installation you change the standard webroot to /var/www/html/nextcloud (when installed it is /var/www/html)

Now this was the problematic thing for me. I told my reverse proxy to use this url This works for web based use. But if you also use the nextcloud android client it becomes an issue.

Well this also tells me why the logs where empty. It could not connect to this url (only android client) so there was nothing to log.

I hope this helps someone that is having the same issue.

That’s a description of the problem but now how you solved it. How did you solve it?

I changed the webfoot from

/var/www/html/ To /var/www/html/nextcloud/

This was the solution to my problem.

I can load documents in the android client just fine, but try editing and you will experience the flickering keyboard that then disappears. Editing experience on android is practically useless until this issue is fixed.

I edit it directly from the nextcloud client on Android.

Seems to be working ok on my end.