Onlyioffice fails when loading document

This was working a few days ago, now onlyoffice just keeps trying to load the document and eventually fails. Both onlyoffice and nextcloud are installed via docker on a Synology NAS

II don’t know what logs may be usefull

What build number is mentioned in the upper right corner when you press the save button?

Is it may be 7.3.0.x ?

Have you tried to downgrade your docker image to the 7.2 … in my case the is still working!

Same here but with the debian packages from the repository, last night it upgraded from 7.2.2-56 to 7.3.0-184-stretch.
I had to downgrade to 7.2.2-56 and recover some configuration files from the package that went missing (don’t know why) .
The error I could see in /var/log/onlyoffice/documentserver/docservice/out.log is

[2023-02-02T09:22:08.966] [WARN] [localhost] [docId] [userId] nodeJS - 3
[2023-02-02T09:22:08.966] [WARN] [localhost] [docId] [userId] nodeJS - Bad request
[2023-02-02T09:22:08.966] [WARN] [localhost] [docId] [userId] nodeJS - { name: 'TRANSPORT_HANDSHAKE_ERROR' }
[2023-02-02T09:22:19.123] [WARN] [localhost] [docId] [userId] nodeJS - <ref *2> IncomingMessage {
1 Like

I understand right that with the downgrade to the onlyoffice is again working for you?

If so then it seems same case as mine - i posted my error yesterday for the docker image on the same server as my nextcloud server.
Nothing of my NC changed concerning Onlyoffice AddOn but the image version.

But i am still not sure if the bug comes from the image or from the AddOn that might need an upgrade?

Yes, even though I’m not using docker images, downgrading the onlyoffice-documentserver debian package “solved” the issue.
I don’t know if the problem is the addon or the documentserver, I can only say that the addon is the latest version available (tested on nextcloud 22, 24 and 25).

1 Like

OK, you are using the debian pakage for the document server.

I have installed 7.6.8 of the AddOn in Nextcloud for NC 25.0.x
Never the less it seems as if the combination of that with onlyoffice version 7.3 ( don’t harmonize.
The docker image isn’t maybe that different from your debian pakage so there might be a way of further investigations by one of the maintainers of the Onlyoffice AddOn / Nextcloud / Onlyoffice

Others should have same probs, but not all are posting it here. (and sure not all NC users use Onlyoffice as well)

1 Like

Yes, I’m usin watchtower to update my docker images, and I"m using onlyoffice:latest. I exported my settings (ports/volumes), change the version to and it works!

Debian package 7.3.2-8~stretch solved the issue for me.

also see here: ONLYOFFICE does not start using latest document server docker image 7.3.x - #17 by chrissi55

but sadly editing and opening document files on a (my) external storage is also with this version a prob.
NFS shares → mounted to NC Server → owned by www-data:www-data → included as external share (local folder) delivers errors in document server.

The question is status “open” waiting for answer from the community / admins
NC 25.0.x Error while downloading the document file to be converted - #2 by chrissi55