No domain/server-root after install view, redirects to non-existing: http://index.php/core/

raspberry 4 - debian10 arm64
docker-compose (based on: docker/docker-compose.yml at master · nextcloud/docker · GitHub)
image versions are pinned to: redis: 5.0.11, mariadb 10.5.9
observing the error for any nextcloud image after: 20.0.8-apache (excluded)
tested with same behavior: 20.0.9, 21.0.2, 21.0.3 (-apache)

this thread seems to describe the same behavior: Redirect to non existing page http://index.php/core/apps/recommended the answer is not helpful as apache is part of the docker image

reloading the install page show the following in nextcloud.log line, looks to me like a confirmation that server-root is empty:
{"reqId":"<reqid>","level":2,"time":"<datetime>","remoteAddr":"<localip>","user":"--","app":"no app in context","method":"GET","url":"/","message":"Could not detect any host in https:///data/htaccesstest.txt","userAgent":"<agent>","version":""}

browser console shows nothing suspicious.

Digging (just a little) into the code makes the impression to me that OC::$SERVERROOT is simply empty.

Any hints where to continue searching would be highly appreciated, like:

  • Who is populating OC::$SERVERROOT?
  • What can I do to further debug this?
  • What could have changed from 20.0.8 onward what could lead to this issue?

Sadly I cannot reproduce this on a regular x64-arch, so this might be even arm related?


Try adding 'overwrite.cli.url' => '' to your config.php

Thanks for the idea @Larry_Boyd,
but this does not help, still the same behavior, I also tried different cli.url entries, but none of them seem to have an impact.

It might also be worth to share that despite this very first redirection after entering the admin user all the other things work. So if I enter the URL by hand I end up (logged in) in a properly set up Nextcloud instance.

Any other ideas maybe?

for completeness: Redirect to non existing page http://index.php/core/apps/recommended - #5 by Savimaki

the issue is now a “known issue”