Nicht auffindbare Datei

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home users. If you’re running a business, get help on portal.nextcloud.com so we can make sure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Remember, the below information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Please delete everything above when creating your topic and provide the following:

Nextcloud version (eg, 12.0.2):13.0.0
Operating system and version (eg, Ubuntu 17.04): Ubuntu 16.04.4 LTS‬
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1):

The issue you are facing:
Nach der Installation haben einige Dateien den Integritätscheck nicht bestanden. Ich habe alle Einstellungen und die entsprechenden Dateien gefixt. Nur das Problem das in der Liste der Dateien die den Integritätscheck nicht bestanden haben kann ich nicht lösen.
Weiter unten steht de Link zu der Datei oder Ordner die ich eigentlichlöschen soll. ich habe auf meinem Server über Filezilla alles so eingestellt dass ich alle Dateien angezeigt bekomme. Nichts ist zu finden.
Die Endung der letzten Dtei ist wohl temporär, da sich der Name imemr dann ändert wenn ich mich neu einlogge und einen Rescan mache.
Kann mir jemand da vielleicht helfen? ich kann das benötigte Update est dann machen, wenn alle Probleme gelöst sind
Danke im Voraus.

Is this the first time you’ve seen this error? (Y/N):y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

PASTE HERE
```Results
=======
- core
	- EXTRA_FILE
		- lib/private/oc_tmp_30IdHo-folder/.htaccess


The output of your config.php file in `/path/to/nextcloud` (make sure you remove any identifiable information!):

PASTE HERE


The output of your Apache/nginx/system log in `/var/log/____`:

PASTE HERE

Führe ein manuelles update durch.

Selbst das ist nicht so einfach zu machen.
Die vorherige Installation war komplett ok, und ich habe alle Datein die gestört haben gefixt.
Das oben benannte Problem soll auch was mit dem Cache zu tun haben.
Hier ist noch ein Hinweis im System:

  • Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der Leistungsfähigkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen finden Sie in der Dokumentation.

Bitte überprüfe noch einmal die Installationsanleitungen :arrow_upper_right: und kontrolliere das Protokoll auf mögliche Fehler oder Warnungen.

Ich finde die besagte einstellung in meiner Konfiguration nicht.

Beste Grüße
Kobra

A memcache is not required and you may safely ignore the warning if you prefer.
https://docs.nextcloud.com/server/13/admin_manual/configuration_server/caching_configuration.html
Das ist nur eine Warnung und kann, wenn man es nicht möchte, ignoriert werden.
Ich weiß bei bestem Wissen nicht, welche Version deine vorherige Installation war, die Ok war. Also probierst du gerade die alte Version auf eine neue zu updaten und beim Update erscheint der Fehler? Hast du die denn dann gelöscht die Dateien?

Eigentlich schon.

  1. Maintenance mode aktivieren
  2. Backup machen von NC und MySQL
  3. Neues Update hochladen und alles überschreiben
  4. File Permissions anpassen (Punkt 9: https://docs.nextcloud.com/server/13/admin_manual/maintenance/manual_upgrade.html ; Und ja das geht auch mit Filezilla :wink: )
  5. Website aufrufen und Update durchführen.
  6. Wenn nicht möglich maintenance Modus deaktiveren und dann Update durchführen.

Ich kann dir gerne bei Teamviewer behilflichsein und bin auch im IRC (Nick xXSTrikeXx) erreichbar (wird periodisch abgerufen). Aber momentan weiß ich auch nicht viel mehr als du :wink:

LG

Hallo, die Installation war komplett neu. Es gab keine restdateien oder sonstige Dateileichen.
Die Datenbank ist auch neu. Sogar den Server habe ich im Rahemn eines Updates aufgewertet und neu installiert.
Ich habe noch in dne Logs den Fehler entdeckt das er das Verzeichnis /tmp vermisst. Dieses ist auch nirgendws zu finden.
Danke für das Angebot über Teamviewer. Müsste man bei gegebener Zeit, wenn es zeitlich passt, eventuell mal machen.
LG

Benutz du apache oder nginx?
Hat php Zugriff auf das /temp Verzeichnis?
Wenn es nur um die .htaccess Datei geht, kann dies vielleicht helfen:

Ich benutze Apache, zumindets ist nur dieser Dienst gestartet.
Es gibt auf der ordnerstruktur keine /tmp Verzeichnis.
Hir der entsprechende Auschnitt aus dem Errorlog:
“user”:“Administrator”,“app”:“PHP”,“method”:“GET”,“url”:"/index.php/settings/admin/log/download",“message”:“is_writable(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/var/www/vhosts/kobra-it.de/:/tmp/ :/dev/urandom) at /var/www/vhosts/kobra-it.de/cloud.kobra-it.de/lib/private/TempManager.php#260”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0”,“version”:“13.0.0.14”}

Hat keienr eine Idee waru mdastmp_verzeichnis nicht da ist und ob ich es einfach so erstellen kann?
Oder muss ich wirklich alles neu installieren?
Kann mir nicht vorstellen das es so sein muss.

Versuch doch eine Neuinstallation mit:

sudo apt-get install --reinstall apache2

Hallo STrike,
ich glauben icht das es an der Installation von Apace 2 liegt.
Die anderen Fehler habe ich ja auch bereits gefixt.

Dann schau mal per phpinfo(); als phpscript nach, woher apache die tempverzeichnisse hat.
Ansonsten schau in die logs :wink:
Was benutzt du für einen server?