Nextcloud Update Error for 18.0.4

Turns out I have different messages when I try to connect with my phone (cannot write into “apps” directory) or desktop (maintenance mode)

and from what I can tell/do, that’s not a cache issue… I really don’t understand this

Hmm

Some modules are missing :slight_smile:

Activate them with :
a2enmod headers
a2enmod env
a2enmod dir
a2enmod mime
a2enmod rewrite
a2enmod php

and service apache2 restart
And let me know if the problem persists

all but php say “Module xyz already enabled”, php doesn’t exist apparently

thanks for your time already though…

/e: specifying php 7.3 did work though. (already enabled)

no change

/e: not allowed to answer ("new users temporarily limited to 3 answers in a single thread), hopefully you can see this:

https://pastebin.com/GHyQ5Qd0

should ™ be default, except for:

<Directory /var/www/> Options Indexes FollowSymLinks AllowOverride All Require all granted </Directory>

where I changed from AllowOverride None to AllowOverride All (to fix an issue)

/e3:

cat /etc/apache2/sites-enabled/nextcloud.conf
<VirtualHost *:80>
ServerAdmin admin@example.com
DocumentRoot /var/www/html/nextcloud/
ServerName nextcloud.example.com

 Alias /nextcloud "/var/www/html/nextcloud/"

 <Directory /var/www/html/nextcloud/>
    Options +FollowSymlinks
    AllowOverride All
    Require all granted
      <IfModule mod_dav.c>
        Dav off
      </IfModule>
    SetEnv HOME /var/www/html/nextcloud
    SetEnv HTTP_HOME /var/www/html/nextcloud
 </Directory>

 ErrorLog ${APACHE_LOG_DIR}/error.log
 CustomLog ${APACHE_LOG_DIR}/access.log combined

/e4: holy crap, this got it, thanks for pointing out where to look!
You were right, I just needed to disable maintenance mode (and after that fix the owner of the files with the command chown www-data:www-data you already mentioned), just in the right place:

SetEnv HOME /var/www/html/nextcloud

For some reason (propably an attempt from way earlier) I had a very old nextcloud instance in /var/www/nextcloud, but the one that I was using (that apache knows about) is in /var/www/html/nextcloud.

Which explains why I “fell down” in version from 17 to 14, and of course why changing maintenance mode didn’t do anything.
I didn’t change anything in the actual instance I was working with.

Holy crap, thanks for your help.
Sorry for wasting your time.
That was a weird one for me, although of course entirely my fault.

I don’t remember putting a nextcloud there… But I apparently did.

Thank you, I’m back to working.
(Also kinda sorry for hijacking the thread)
Solved for me as well