Nextcloud Talk - Black screens, STUN/TURN setup and other failures

I have tried for days to get Nextcloud Talk working, but have not succeeded. Other WebRTC services such as and work . on one device (laptop) shows all checkmarks except for the Reflexive Connectivity, which shows a warning. I have tried with NC Talk for Android as well as Chrome and Firefox, both under Linux and OSX. The devices attempting connections are always behind a home router.

I have set up a turn server with this /etc/turnserver.conf:

listening-ip=999.999.999.999  # IP redacted
relay-ip=999.999.999.999  # IP redacted
static-auth-secret=secretredacted  # not the same subdomain used for Nextcloud
no-udp  # I have tried with and without this

In the Nextcloud config, under the Talk section (left side menu entry), I put

STUN servers:
TURN server:
with a shared secret that matches what was in the turnserver config
I have tried both “UDP and TCP” and “TCP only”
I have left Signalling Server empty.

I see no lines describing attempted connections in turnserver.log . I see no Network requests for the turn server in the Network tab of the web developer tools. All I get on either side are black screens, with only the local (mirror) camera showing anything, never the other side.

I am able to control the OpenWRT on one side, if any ports need to be forwarded or anything.

I have been at this for days, and am close to giving up. Assistance appreciated.

Nextcloud 13.0
Nextcloud Talk 3.2.2

1 Like

did you try this


Are Nextcloud and TURN on the same server and are they behind a NAT? In letter case, try to remove/comment listening and relay IP.

Does it actually work from within the local network?

Check out as well: HowTo: Setup Nextcloud Talk with TURN server

@MichaIng Thank you for your response! Nextcloud and the STUN/TURN server are indeed on the same server. They are public to the Internet, but with different subdomains. I have already tried using the same subdomain (the nextcloud one), and it didn’t help. I have not tried having the callers and the server all on the same network. The server is remote. I suppose I could try to fake being on the server’s network using SSH port forwarding perhaps? Should I try?

@Reiner_Nippes Sorry, I didn’t see your message until now. I have followed the spirit of those instructions already, which I have seen described on several different websites already.

More data: If I change the Nextcloud Talk config to have garbage (a non-existent domain) in the TURN server field, the behaviour is still the same (black screens). So, it’s like that field is either not used at all, or it is not using the provided TURN server config at all. Or who knows what.

I found some success after I:

  1. Updated the Talk app from 3.2.2 to 3.2.4.
  2. Fully closed the Android app and restarted it, instead of just closing the call/conversation and reopening it.
1 Like