Nextcloud Social v0.1.3


While we’re working on the alpha v0.2 of the Social app, including a lots of feature like Hashtags and Attachments to Post, we are also releasing a new version of the alpha1 (v0.1.3) that should fix most of reported bugs:

  • [global] fixing an issue displaying timeline when opening details for a local account.
  • [global] provide more details in logs on async failure.
  • [global] Cache refreshing on some events (new post, new follow)
  • [federated] adding security @context on returned Actor.
  • [federated] signature can be 5min old (instead of 30s) to avoid issue on badly configured instance of Nextcloud.
  • [federated] webfinger will also check the host of the account.
  • [UI] do not clear post field on fail post creation.

Thanks a lot to everyone who is testing the app.

1 Like


seen the app some days ago.
To be honest for it is not clear what to do with it?
Is there a video or any other resource which explains the aim of the app?

I tried to send a message to another NC instance using federated notation but the message does not arrive.
Do I have to pair both clouds before?

Best regards

Might be too soon for a video tutorial, as the app is still in alpha, but the purpose of the app is to provide you with a social account on the ‘feduniverse’ which is a decentralized social network.

The app will generate an account that can communicate with others accounts on others instances of ActivityPub on the Internet: other nextcloud with the social app installed but also other social networks like mastodon, friendica, …

You can see that as a Twitter-like social media, but decentralized and open-source.

1 Like

Hope you can add support for custom ports in the future.

@alfred you should be able to do that already, but you will still need the ability to forward the .well-known from the default port to your custom port.

Untested example for apache2:

SSLProxyEngine On
ProxyPass /.well-known/
ProxyPassReverse /.well-known/

If this is too global, you can narrow the redirection to .well-known/webfinger only

how could it be setup for a nextcloud container running on a NAS?
I access my instance via https 443, but not able to communicate with mastodon for example.

OK how do we actually use social? I turned it on. I have a user. I tried to send a message to myself on a mastodon instance. It didn’t get there. I tried to send a message to myself from a mastodon instance. It didn’t get there. I don’t know how to find or follow a person on a mastodon instance… or really do anything but post text to a box that doesn’t go anywhere? With no errors or anything? I’m using the version in the app store, 0.1.3, on a recent install of nextcloud 15.0.2.

Apologies if I’m missing something obvious or expecting more than is there to be found, but I dig mastodon and it’d be cool to be able to intereact with it via my nextcloud instance.

Having the same issue as the user before me (on v0.1.3 still). Happy to test, but without functionality or error messages there is not much else to report than that it doesn’t connect’.'Not sending messages not being able to follow. Hope we can get an update to really test with soon.

BTW Don’t get me wrong, I’m really interested in this, so keep up the good work.

1 Like

hi, i’m using the most recent version of the Social app. Connecting to the Nextcloud mastadon adres doesn’t work. I neither see an option for searching for other accounts to link with or something like that? What is already possible and what isn’t? Is there already any manual available?

The social app uses the standard search field (the magnifying glass in the upper right corner). If you enter an account (@user@mastodonserver.tld) you are able to see the user’s profile. There you can then click the follow button.
Please be aware that a few things changed and stopped working with the latest release.
There is no longer a stream under “Home”, but only under “Global Timeline” (and maybe “Local Timeline” as well, but I can’t test that).

Hope this helps.

i tried to follow but that doesn’t work. pushing the follow button seems to work but when i go to profile or global timeline i see following:0 and no messages on the global timeline.

I believe you don’t see the old posts, but only the new posts published after you followed an account. The last post was an hour ago and it might take a while for the next one.

The number of people you follow and the number of your followers are the things that stopped working. These values a zero for me too.
There hasn’t been much work on the Github repository. It probably takes some time until the next release with some fixes is published.

but even the nr of followers is not updated, that is strange isn’t it?Schermafdruk%20van%202019-09-18%2019-57-29

Well, there is some activity; we’re daily working on the app !
The issue can come from your setup, can you please send me ( the result of those commands:

./occ config:app:get social cloud_url
./occ config:app:get social social_url
./occ config:app:get social social_address

and the host of your nextcloud ?

There hasn’t been activity in github for social for 2 months. I am still considering whether I should start using it seriously. Is it still planned to improve it any further? No pressure, just curious.

Hello, no pressure taken :wink:

You should wait for at least the next Alpha before using it, as a lot of modification are expected in the database that might lose your social data.
I am unfortunately our of free time right now, but I hope to come with a descent release next month.



mmc@xxx:/var/www/html/nextcloud$ sudo -u www-data ./occ config:app:get social cloud_url
mmc@xxx:/var/www/html/nextcloud$ sudo -u www-data ./occ config:app:get social social_url
mmc@xxx:/var/www/html/nextcloud$ sudo -u www-data ./occ config:app:get social social_address

I also have nothing with this command :
sudo -u www-data ./occ config:app:get social social_address

I can’t follow anyone in the fediverse, i can’t send private message to other users