Nextcloud is broken after changing server

Hey there !

I was using Nextcloud on my server for a little more than 3 months, and decided to change to a more powerful server.
I downloaded the whole nextcloud folder, and uploaded it to the new server.
I also uploaded the same configuration, and exported then imported the database.

When reaching my website adress, the login form appears, without any problem, but when I log in, it takes around a minute or so to load, and when the loading is ended, the css is broken, and I have some weird errors in console.

And that’s just a fraction of them…
I tried to restart php, run occ maintenance:repair and all those maintenance commands, but the problem is still here.

I tried to reinstall nextcloud from a fresh install, and upload the data, import the database for the configurations and users, but there’s some weird bugs :confused:

I really don’t know what to do, I can’t take the time to reconfigure everything x)

Please test it for this file:

Please post

ls -l path-to-nextcloud/core/js/merged-template-prepend.js
cat path-to-nextcloud/core/js/merged-template-prepend.js
md5sum path-to-nextcloud/core/js/merged-template-prepend.js

Post the version of your backup and your installation.
Both find in config/config.php (your backup and the actual version)

I think you use a wrong nextcloud version for your backup.
Install the version for your backup:
Hope it works. Normally you only restore all data and db.


Hey, thanks for the answer!

The problem is solved after reinstalling nextcloud and importing the db etc, there’s some remaining bugs (for example, the password app is loading for 30 seconds instead of the 1-2s I was used to, and for the moment that’s the only bug I’ve seen)

EDIT: Oh and in the logging page, I have this error being sent 4-5 times every 10 seconds:
Trying to access array offset on value of type null at /usr/share/nginx/html/cloud/3rdparty/leafo/scssphp/src/Compiler.php#5230

And… just to clarify, I was using the same version everywhere (18.0.6) ^^

Read. Perhaps one of the solutions helps.

Thanks for the post, I’ll check that out.

And in fact there’s a lot of other bugs, sometimes the server doesn’t respond, when I try to log in using the nextcloud Android app I click “Authorize” and the in-app loading is infinite, when I log in using the TOTP 2FA it throws an http error code I guess, I don’t understand why, I never had these problems before.

Perhaps you must change other configuration e.g. php-settings, …

I already changed the default configuration, there’s 2 Gb of ram allocated and I’ve done everything I did on the old vps.
I also managed to fix some of the authentification problems by clearing some tables in the database.