Nextcloud clients can't be linked to the server anymore

Hi! :smiley: So…:cocktail:

…a week or two ago I lost Internet access for a couple of days, on those very days the Let’s Encrypt certificate expired an naturally it showed warnings when accesing. Earlier than that though I had revoked access to all the apps in my account because it was just a hot mess so I could delete all files in my account without fear of it syncing back.

Certificate was auto-renewed as soon as I got Internet access back, the last thing I remember doing was adding the Nextcloud and Nextcloud Talk apps in an Android phone. Then I tried to link a password manager app on the same Android device but I got it to connect but it won’t sync.

Furthermore password manager browser extensions tell me the URL is invalid or the API is disabled. So I guess all I have to do is reenable the API, is that really is the issue.

In the past I’ve been able to simply select to log in directly, which was sort of expected because I’d be messing with the servers (I’m using Active Directory Federation Services for Single Sign-On / SAML) but everything’s stable now and not even that works.

On the desktop app I get this:

It’s eternal spinner and in the end it just loops back to log in again. Here’s the password manager app on Android:

Adding to confusion, GNOME shell connects fine, I’m not really sure what does it connect for but it does. I turned on an Android device which was one of the revoked clients (Nextcloud official app; it had been turned off for a longer period) and it tried to sync for a while, then it repeatedly asked me for my fingerprint–well, actually for my passcode but only the fingerprint would work–and eventually kicked me out and redirected me to ADFS to log in, I did and it reauthorized the app and showed me a file list but I don’t know if it’s what’s cached or what’s local to the device.

Then it kicked me again. I chose ADFS again to login, entered my credentials and granted authorization, it went through again and got me to main app screen but it’s forever loading:

Sorry for the bad screenshot; the sum of Diet Coke jitter, a broken screen (the reason it was turned off) and acccidental MDM screenshot lock.

If it is the API disabled thing, how is it reenabled? Can it be done with the magic executable/file that’s run under another executable (php) under another user account on the command line? I’m a little afraid to ask the other question 'cause I imagine it would be easier to install a new server. :frowning_face:

Like most servers Nextcloud is actually a virtual machine–with snapshots–and I thought, since it’s just me using it anyway, I could just snapshot back to a working point in time, however, it has write access to the directory (for password changes) and changes in the directory have been made since the last snapshot, I don’t now how damaging could it be if I snap back.

Anyway, I hope you can advice me a little on this. Thanks for your help! :smiley:


I saw a different explanation, of the same thing, made a snapshot and clenched hard on my jaw while Apache restarted and it worked fine! :smiley:

The weird thing is that I am not using a reverse proxy, I mean, I am, but not on the Intranet to Nextcloud, neverthelesss it work. I hope there aren’t any issues when it’s time to renew certs. :upside_down_face: