Nextcloud-client install on debian-9-32 bits


#1

Hi there and happy new year !
on my pc I used to sync via owncloud and would like to migrate to nextcloud.
on the 64-bits-pc, the appimage exists.
but for my samsung nc10-32 bits, on which I installed the debian-9, I don’t know howto install it.
if using the (ubuntu) ppa, I don’t know what ubuntu version to choose.
the use/install of a ppa on debian is described on the wiki.debian.org, CreatePackageFromPPA.)
here the debian/ubuntu correspondance :
[https://askubuntu.com/questions/445487/ … -on#445496]
17.10 artful stretch / sid
17.04 zesty stretch / sid
16.10 yakkety stretch / sid
16.04 xenial stretch / sid

but:
"in particular Ubuntu is often ahead of Debian on core packages like libc6. Trying to install a package built on Ubuntu on a contemporary version of Debian is likely to end up with version errors on libc6."
here:
[https://packages.debian.org/stretch/libc6]
the version of the libc6 for debian 9 (stretch): stretch: Package: libc6 (2.24-11+deb9u1)

here:
[https://packages.ubuntu.com/search?keywords=libc6]
we can find: zesty (libs): GNU C Library: Shared libraries 2.24-9ubuntu2.2 [security]: amd64 i386

1/ do you think that this kind of install could corrupt the debian system ?
2/ if not, what libc6 to use ?

thanks in advance
nexti


#2

Hi,

there is repository created specifically for Debian 9: download.opensuse.org/repositories/home:/ivaradi/Debian_9.0/


#3

ok, thanks very much !

so, for the nextcloud-client_32bits, is it this one :
[ ] nextcloud-client_2.3.3-20171224.060956_i386.deb ?

no need to install none of the other ones :

libnextcloudsync-dev_2.3.3-20171224.060956_i386.deb
libnextcloudsync0-dbgsym_2.3.3-20171224.060956_i386.deb
libnextcloudsync0_2.3.3-20171224.060956_i386.deb
libqtkeychain1-dbgsym_0.7.0-1.0_i386.deb
libqtkeychain1_0.7.0-1.0_i386.deb
nextcloud-client-dbgsym_2.3.3-20171224.060956_i386.deb

nextcloud-client_2.3.3-20171224.060956_i386.deb

qtkeychain-dev_0.7.0-1.0_i386.deb


#4

I possibly understand that all of them have to be installed and after trying, I get some dpkg errors:
nextcloud-client depends on nextcloud-client-l10n, but there is ‘no candidate version’.
any idea for that one ?


#5

nextcloud-client-l10n is in the all subdirectory.

But you do not have to install the packages manually. You can add the repository to your /etc/apt/sources.list file and install the package with apt-get. Please, see the Installing on Debian section of the README for more details.


#6

Hi ivaradi and thank you very much :sunglasses:
I first went here [https://nextcloud.com/install/#install-clients]
then: [https://launchpad.net/~nextcloud-devs/+archive/ubuntu/client]
add the ppa and this didn’t work.
so I tried to install the deb directly and wasn’t lead to the ‘installing on debian’ : I was lost :slight_smile:


#7

Use the Ubuntuy zesty one. Works for me on Debian 9 64 bit.

deb http://ppa.launchpad.net/nextcloud-devs/client/ubuntu zesty main