NextCloud 13 memory info not available

Server configuration detail

Operating system: Linux 2.6.32-042stab123.3 #1 SMP Fri May 5 12:29:05 MSK 2017 x86_64

Webserver: Apache/2.4.29 (Ubuntu) (apache2handler)

Database: mysql 10.0.33

PHP version:
Modules loaded: Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, session, standard, apache2handler, mysqlnd, PDO, xml, apcu, apc, bcmath, calendar, ctype, curl, dom, mbstring, fileinfo, ftp, gd, gettext, iconv, imagick, intl, json, exif, mcrypt, mysqli, pdo_mysql, Phar, posix, readline, shmop, SimpleXML, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xmlreader, xmlwriter, xsl, zip, Zend OPcache

Nextcloud version: 13.0.0 -

Log: is_readable(): open_basedir restriction in effect. File(/proc/meminfo) is not within the allowed path(s): (/var/customers/webs/PortStone/NextCloud:/tmp:/dev/urandom) at /var/customers/webs/PortStone/NextCloud/apps/serverinfo/lib/SystemStatistics.php#74

So I added (in Froxlor) ‘Paths to append to OpenBasedir’ /proc/meminfo but it still don’t work. If I look at the vHost config file it will not be added.

Same here

sudo -u httpuser cat /proc/meminfo
works fine

Can you check that the correct php.ini was edited?
Could you post the complete line of open_basedir from your php.ini?

Yes it was the correct php.ini because I can see the changes.

Standard php.ini configuration
;open_basedir =

Froxlor handles it over vHost configs as you can see below.
php_admin_value open_basedir “/var/customers/webs/PortStone/NextCloud:/tmp:/dev/urandom”

As you can see it misses :/proc/meminfo but it will not add it and I dont know why. I thought it is generally not allowed or something like this. If i add it manually it doesn’t work either.

sudo -u www-data cat /proc/meminfo didn’t worked

Fix if you use Froxlor:

froxlor does not allow that you select a path like /proc (for security reasons).

Disallowed are: /dev (except urandom), /proc, /etc, /sys and of course /

Current solutuion: deactivate openbasedir for that domain

If you need your openbasedir you can add this to your line “:/tmp/:/proc/meminfo” that solved the problem and is NOT a security problem, because you say with this only that www-data php can execute /proc/meminfo and not all files of the /proc folder

I confirm this command is worked (/proc/meminfo)
I add to conf of apache2 /sys/class/net/lo:/sys/class/net/eth0:/sys/class/net and this show network IP and local IP.
I have add this in conf:
php_admin_value open_basedir /var/www/nextcloud:/sys/class/net/lo:/sys/class/net/eth0:/sys/class/net:/proc/meminfo:/var/www/nextcloud/tmp:/bin:/usr/bin:/usr/local/bin:/var/www/html:/tmp:/usr/share:/etc/phpMyAdmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/urandom