NCP re-initialized itself

Just be careful not to run out of space again. You can compress backups, and keep just a couple instead of four to start with.

Also you can do dataless backups and backup the data by other means, such as nc-rsync or nc-snapshots

Okay, apparently when I enabled backups again (limited to 2) NCP didn’t delete the old backups and therefore everything crashed again. After repairing the system using the method above,
I now went through all the folders using the sudo du -msh command to see what is using up all the space.

25GB are used by the folder /var/www/nextcloud/data/ncp-update-backups with the two files
nextcloud-bkp_20180620_1529476021-13.0.2.1.tar.gz and
nextcloud-bkp_20180726_1532586352-13.0.4.0.tar.gz. Why are they being kept? Is it save to delete these files?

Most of the rest of the space was used by personal files (about 160GB) and backup files. These files where about 36GB each! Why are they so huge? Is that normal? What do they contain (apparently not all the data, they would be much bigger)?

[ nc-backup ]
check free space…
Maintenance mode enabled
backup database…
backup base files…
compressing backup file…
backup /media/nc-backup/nextcloud-bkp_20181009_1539101020.tar.gz generated
Nextcloud is in maintenance mode - no apps have been loaded

Maintenance mode disabled

The old backups are only deleted after a successful backup. Also, the backup tool checks if there is space available, but that might not be true if there’s compression, because the compression is not in-place. I just realized that, it needs to be improved.

You can safely remove the old backups in ncp-update-backups. Those are there in case something goes wrong with the update and you want to go back. They are surprisingly big though, can you check what is the size of your previews? (they will be in a path similar to /media/myCloudDrive/ncdata/appdata_oc65v9pdw1g0/preview)

Well, we found a couple details to work on :smiley:

Hello there,
i have similar problems. fortunately my nextcloud is running fine (i hope) but i was surprised, that the sd card with 32gb was filles with 19gd. I use only the calendar and have there 2 - 3 small pdf files. I’m not that linux guru but with
sudo du -m | sort -n | tail -n 10
I got this output:
du: Zugriff auf ‘./proc/6769/task/6769/fd/3’ nicht möglich: Datei oder Verzeichnis nicht gefunden
du: Zugriff auf ‘./proc/6769/task/6769/fdinfo/3’ nicht möglich: Datei oder Verzeichnis nicht gefunden
du: Zugriff auf ‘./proc/6769/fd/4’ nicht möglich: Datei oder Verzeichnis nicht gefunden
du: Zugriff auf ‘./proc/6769/fdinfo/4’ nicht möglich: Datei oder Verzeichnis nicht gefunden
292 ./lib
341 ./usr/share
420 ./usr/lib
1006 ./usr
15011 ./var/www/nextcloud/data/ncp-update-backups
15449 ./var/www/nextcloud/data
15682 ./var/www/nextcloud
15684 ./var/www
16137 ./var
17865 .

As I read this well, in the folder ./var/www/nextcloud/data/ncp-update-backups I have 15gb. I’m connected via ssh but i cannot enter this folder to take a look, what files are so huge and to try to delete something to get free space back. As I’m no linux guru I would be very happy, if someone could help me step by step to solve this problem befor my nextclout re-initiates like described here and let me in get in a situation, where no one can help me anymore :wink:

this are backups from (auto)updating to newer nextcloud versions. If everything works fine you can safely delete them

Solved. I used sudo -s and then it worked.