[NCP] Nextcloud check error

there is btrfs-check, did you try it?

I did, no errors were found… It’s like the USB devices are safely removed after being automounted… I tried with a USB stick as well… lsusb shows nothing…
I have a instance backup, if i flash the NCP image to the sdcard again and restore from backup would it help? And how should I proceed with the data dir then?

Clearly my raspberry pi’s USB doesn’t work as expected anymore. I tried with usb stick as well, it loses power sometime after plugging in. I contacted the warranty service, lets see what happens. I ordered a Rock64 as a replacement. Thanks for the suggestions!

Continuing the discussion from [NCP] Nextcloud check error:

I am experiencing exactly the same issue. This happened after i installed the v1.20.7. Interestingly enough when typing in

ls -lh /media/

during boot-up it appears as if the drive is being mounted. Once the NCP is fooly booted it disappears.

On Raspberry Pi 4?
I’d first install another OS on a second sdcard and see if the problem persists…

Indeed the Raspberry Pi 4. I have tried exactly what you suggested. What I can report is that problem persists. I have tried it with three different drives, to ensure that it is not an issue caused by the HDD or SSD. What I have noticed though is that this is only caused by the USB 3 ports. There are absolutely no issues to report with the USB 2 ports.

I am having the same problem on a Raspberry Pi 4 using a USB 3 port.

The “internal server error” occurred and MariaDB went down.

I did a complete reinstall of the NCP image and less than a day later, I am getting the same error.

Maria DB is still up, but I am now getting the “Nextcloud check error.”

I will try it with a USB 2 port.

EDIT: switching to a USB 2 port brought Nextcloud back up. I will report back if it goes down again.

I tried with USB 2 ports and had the same problem unfortunately. Contacted the warranty service where i bought the Pi4 to get it checked but if you guys are having the same problem, it might be an problem caused by an update…

After a day or so, my NCP/Nextcloud instance crashed again. This is after moving the external drive to a USB 2 port (on a Pi4). The first time this happened, I could not access Nextcloud, but could still access the NCP page (:4443). This time I cannot access either one.

The Pi4 seems to be down entirely this time as I cannot ssh into it. I will reboot it and see how long it stays up.

This issue started with the most recent update.

Hi any news on this guys ?

I haven’t tried again yet as the cloud is now perfectly set up. I am waiting for a nextcloudpi update. Has anyone else had any success?

BTW. I had the same issue as @jaw. That’s when i decided to newly install nextcloud and run it off USB 2 until this issue is fixed. I might have a try with a separate SD and a SSD when I get time.

Hi, exactly the same problem Rpi 4. So far with a smaller USB 64GB everything was working. When I changed the USB to 1 TB SSD disk there was a problem already during the installation. I solved the problem by booting from SSD. Everything is great now!

Anyone of you tried connecting the drive not directly to the pi but through a powered usb hub? It may be a power problem after all

Thats what I thought… It was the first thing I tried but it didn’t work…

I tried it with a 128 GB usb stick, didn’t work either. There has been a kernel update, I will try again in the next few days and see if everything is back to normal… It’s a real bummer for the Raspi 4 users…

I tried the same with the hub, and a dive that has a separate PSU - neither worked. The weird thing is though that it works perfectly fine on USB2.

The latest kernel update fixed the problem for me. Everything works as intended now.
‘sudo apt update && sudo apt upgrade’

Hello everyboy,

today I am getting the same error and need you help please.
After the installing and configurating nextcloud on the Raspberry Pi4 with the nexcloudpi Image I have making a ‘sudo apt update && sudo apt upgrade’ an a reboot.

Nextcloud don’t want to start now and the Nextcloud check shows a error on MYSITE:443

I am getting the following fault:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.

Can anyone help me please?

my Config log

<?php $CONFIG = array ( 'passwordsalt' => 'xxx', 'secret' => 'xxx', 'trusted_domains' => array ( 0 => 'xxx', 11 => 'xxx', 1 => 'xxx', 12 => 'xxx', ), 'datadirectory' => '/var/www/nextcloud/data', 'dbtype' => 'mysql', 'version' => '', 'overwrite.cli.url' => 'xxx', 'dbname' => 'xxx, 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => 'xxx', 'dbpassword' => 'xxxx', 'memcache.local' => '\\OC\\Memcache\\Redis', 'memcache.locking' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => '/var/run/redis/redis.sock', 'port' => 0, 'timeout' => 0.0, 'password' => 'xxx', ), 'instanceid' => 'xxx', 'installed' => true, ); The MariaDB log: root@nextcloudpi:/var/log# systemctl status mariadb.service shows Unit shows.service could not be found. ● mariadb.service - MariaDB 10.3.23 database server Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled) Active: active (running) since Fri 2020-09-11 10:58:11 BST; 36min ago Docs: man:mysqld(8) https://mariadb.com/kb/en/library/systemd/ Process: 583 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS) Process: 598 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS) Process: 606 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= || VAR=`cd /usr/bin/..; /usr/bin/galera_recovery`; [ $? -eq 0 ] && systemctl set-environment _WSREP_STAR Process: 1044 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS) Process: 1046 ExecStartPost=/etc/mysql/debian-start (code=exited, status=0/SUCCESS) Main PID: 758 (mysqld) Status: "Taking your SQL requests now..." Tasks: 31 (limit: 4915) CGroup: /system.slice/mariadb.service └─758 /usr/sbin/mysqld Sep 11 10:58:09 nextcloudpi mysqld[758]: 2020-09-11 10:58:09 0 [Note] /usr/sbin/mysqld (mysqld 10.3.23-MariaDB-0+deb10u1) starting as process 758 ... Sep 11 10:58:09 nextcloudpi mysqld[758]: 2020-09-11 10:58:09 0 [Warning] Could not increase number of max_open_files to more than 16364 (request: 32186) Sep 11 10:58:11 nextcloudpi systemd[1]: Started MariaDB 10.3.23 database server. Sep 11 10:58:11 nextcloudpi /etc/mysql/debian-start[1048]: Upgrading MySQL tables if necessary. Sep 11 10:58:11 nextcloudpi /etc/mysql/debian-start[1052]: /usr/bin/mysql_upgrade: the '--basedir' option is always ignored Sep 11 10:58:11 nextcloudpi /etc/mysql/debian-start[1052]: Looking for 'mysql' as: /usr/bin/mysql Sep 11 10:58:11 nextcloudpi /etc/mysql/debian-start[1052]: Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck Sep 11 10:58:11 nextcloudpi /etc/mysql/debian-start[1052]: This installation of MySQL is already upgraded to 10.3.23-MariaDB, use --force if you still need to run mysql_upgrade Sep 11 10:58:11 nextcloudpi /etc/mysql/debian-start[1105]: Checking for insecure root accounts.

Do you have a Idea please?


Just experienced this myself. Had NCP set up and operating nicely, and then as soon as I changed the location of the data folder - boom - “Internal Server Error” on page load. NCP panel system info showed “Nextcloud check: error”, and “MariaDB Service: down”. After following the guidance here…
[NCP] NextCloud and MariaDB down I was able to get the MariaDB service back up (at least as far as the NCP System Info panel is concerned), but Nextcloud check is still showing an error and I still get the internal server error on the main NC page.

Two months ago I would’ve just said screw it and started from scratch, but I just got done uploaded a ton of photos and videos and I really like to figure out how to get NC running again.

<summary>NextCloudPi diagnostics</summary>

NextCloudPi version  v1.34.1
distribution         Debian GNU/Linux 10 \n \l
automount            no
USB devices          sda
datadir              /var/nextcloud/data
data in SD           yes
data filesystem      ext2/ext3
data disk usage      41G/440G
rootfs usage         41G/440G
swapfile             /var/swap
dbdir                /var/nextcloud/data
Nextcloud check      error
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
Postfix service      up
internet check       ok
port check 80        open
port check 443       open
IP                   ***REMOVED SENSITIVE VALUE***
gateway              ***REMOVED SENSITIVE VALUE***
interface            eth0
certificates         ***REMOVED SENSITIVE VALUE***
NAT loopback         no
uptime               4min