NC Box bricked after reboot

Hi all,

I just logged in to my NC Box with ssh and it said a reboot was required. So I thought I would first run an apt update and apt upgrade but the apt update failed so I then issued the the command sudo reboot and now it appears to have bricked itself. I have tried unplugging it and plugging it back in and have tried connecting a monitor and keyboard but just get a blank screen. No lights on the ethernet port, normally they come on when it boots. If I pull all the power the rpi turns on the red led and briefly flashes the green led. If I just pull the power lead from the rpi only and reconnect then both red and green led stays lit. Led on the hard disc flashes about once a second.

Is there a known bug?

What is the best way to recover this, luckily no data on it yet and I have a backup of the sd card image but I would like to be able to recover this without starting over?

Is there something I did that I shouldn’t have?

Below is my ssh session.

greg@greg-6360b ~ $ ssh ubuntu@nextcloud
ubuntu@nextcloud's password: 
Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-1017-raspi2 armv7l)

 * Documentation:
 * Management:
 * Support:

98 packages can be updated.
49 updates are security updates.

*** System restart required ***
Last login: Tue Jan 10 19:33:38 2017 from
ubuntu@nextcloud:~$ sudo apt update
[sudo] password for ubuntu: 
Ign:1 xenial-wd-nextcloud InRelease
Hit:2 xenial InRelease
Hit:3 xenial InRelease
Get:4 xenial-updates InRelease [102 kB]
Hit:5 xenial-wd-nextcloud Release
Get:6 xenial-security InRelease [102 kB]
Get:7 xenial-backports InRelease [102 kB]
Get:9 xenial-updates/main Sources [213 kB]
Get:10 xenial-updates/universe Sources [117 kB] 
Get:11 xenial-updates/multiverse Sources [4016 B]         
Get:12 xenial-updates/main armhf Packages [416 kB]       
Get:13 xenial-updates/main Translation-en [177 kB]          
Get:14 xenial-updates/universe armhf Packages [340 kB]                                
Get:15 xenial-updates/universe Translation-en [139 kB]                                
Get:16 xenial-security/main Sources [54.5 kB]                                         
Get:17 xenial-security/universe Sources [16.9 kB]                                     
Get:18 xenial-security/multiverse Sources [724 B]                                     
Get:19 xenial-security/main armhf Packages [176 kB]                                   
Get:20 xenial-security/main Translation-en [84.3 kB]                                  
Get:21 xenial-security/universe armhf Packages [69.9 kB]                              
Get:22 xenial-security/universe Translation-en [37.9 kB]                              
Fetched 2153 kB in 8s (255 kB/s)                                                                              
N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
ubuntu@nextcloud:~$ sudo reboot
Connection to nextcloud closed by remote host.
Connection to nextcloud closed.
greg@greg-6360b ~ $ ssh ubuntu@nextcloud

ssh: connect to host nextcloud port 22: Connection timed out
greg@greg-6360b ~ $

I decided to follow the instructions here to recover my install.

It didn’t work, rpi just sat there for 10 minutes with the red led on and hard disc led flashing about once a second. Never got the ethernet leds to come on. So I reflashed the sd card with my backup that I made of the original card and now it’s working again after 10 minutes.

So, questions for the experts, if I ssh into the box and it says System restart required should I ignore that?

Will the NC Box reboot itself to install updates to Ubuntu Core when required?

I am guessing that maybe it was in the middle of updating itself and that was why the apt update failed when I tried to run it?

And that I rebooted at a bad time breaking the install on the hard drive AND the sd card?

Throughout this topic I was going to suggest hardware issue given the ethernet LEDs, but if you’re saying a reflash worked then obviously not.

The image you have is based on ubuntu server, not snappy core, so no you shouldn’t ignore updates and requests to reboot. I’d suggest next time figuring out why it failed to update before rebooting though, as that may have been the crux of the issue.

No known issues; I upgrade and reboot mine regularly.

I am using the image that came with the NC BOX and according to the official website…

The Nextcloud box consists of the following parts:

1 TB USB3 hard drive from WDLabs
Nextcloud case with room for the drive and a compute board
microUSB charger, cables and adapters, a screw driver and screws
microSD card with Snappy Ubuntu Core as OS, including Apache, MySQL and the latest Nextcloud 10 pre-installed and ready to go
The Box does not come with a Raspberry Pi.

The ethernet LEDs seem to be a good telltale to confirm the RPI has booted properly.

Hello Jason,

Reboot is not an issue for me but owing to DHCP lease changes (outside my control) sometimes the IP address of the NC box changes. Thereafter, the browser desktop and Windows notification tray client can no longer connect to the NC box with the newly assigned IP address.

Resetting the disk partitions to original defaults works fine but it is a hassle because I do not want to treat the NC box as a crash-n-burn device (i.e. would like to invest my time in using it truly for the potential NC box offers).

Any suggestions on workarounds that can be configured remotely (short of PuTTY edit of the various config.php files - not sure which one is the latest)?. Thanks.


Set a static IP on the box. You shouldn’t be relying on DHCP for a service you need consistent access to. Tools exist to scan for other IPs on the network and once you have a list it should give you an indication of where the DHCP lease starts (eg you may see,, etc) and you can set an IP far outside of that lease, after pinging to make sure it’s not in use.

If I wasn’t in control of DHCP, that’s what I’d do. It’s possible you’ll hit a conflict one day but not very likely; if you did it’d be easier to resolve with a change of IP than a reboot and wondering where the server has ended up now.

Do keep an eye on it. Even if you did have to reimage the SDCard (which everyone will eventually, SDcards do fail often) you can set it back up without resetting disks. See: Nextcloud Box OS images

1 Like