Issue installing Collabora following official guide

Unfortunately not, I still can’t get Collabora working. Grey box, an issue with iFrames and the URL I think.

I’m using Ubuntu 16.04, Next cloud 10 and newest Collabora docker

I’m installed Collabora docker with guide in https://nextcloud.com/collaboraonline/
After that i’m started Collabora with domain nextcloud (cloud.mydomain.com)

docker run -t -d -p 127.0.0.1:9980:9980 -e "domain=cloud\.mydomain\.com" --restart always --cap-add MKNOD collabora/code

And setup proxy in apache…

But when i start Collabora Onoine , i got error

Collabora Online unknown error: cURL error 56: Received HTTP code 504 from proxy after CONNECT
Please contact the "https://office.ho.fpt.vn" administrator.

Using the CURRENT Docker Image was a total waste of time for me. I even copied out CODE from the docker image using this guide:

I would highly recommend building from source and using loolswsd 1.9.0, This guide can help if you’re struggling to follow the instructions in the readme files in the git repository:
https://gist.github.com/m-jowett/0f28bff952737f210574fc3b2efaa01a:

Hi,
tried to get the docker image running but it doesn’t start. I’m getting the following error message:

docker: Error response from daemon: rpc error: code = 2 desc = "oci runtime error: exec format error".

**Edit:**Ok I’ve found that the docker image won’t work because it should run on my ARM-board (Odroid XU4) which seems not to work.

And aren’t there snap packages (I thought that the Nexcloud-Box comes with preinstalled Snap-Packages)?

Thanks in advance!

Thanks for your article. I’m on Deb Jesssie aswell for the container.

I did the entire kernel bpo upgrade (to 4.7 now) and docker remove/install by script (for aufs integration) etc etc pipapo - STILL the same error message (“unexpected connection error…”)!

I would really like to get some hints from the collabora devs, as I really am tired of spending hours and hours on trying to make collabora work with nextcloud. I’m losing my entire hair on this issue.

Or - and that would be totally legit - tell us we should wait for an official implementation. Or tell us it doesn’t flawlessly work on Debian.

Please - thank you.

Hi Mike,

for me, properly escaping special characters in the domain argument to docker run was the key to success regarding the Error “unexpected connection”: When the VHost with Nextcloud is vhost-name.example.org, you’ll have to give -e “domain=vhost\-name\.example\.org” as commandline argument to docker run. Hope that it helps.

Trying to run Collabora Online (Docker container) and the Nextcloud Richtdocuments App working on a Debian Stretch installation, I get the following error from dockerized Collabora Online when opening a (or creating a new) LO document from within Nextcloud:

[…]
kit-00037-04 00:13:15.142813 [ kit_queue_0002 ] Failed to load: file:///user/docs/37/About.odt, error: loadComponentFromURL returned an empty reference
kit-00037-04 00:13:15.142929 [ kit_queue_0002 ] Failed to get LoKitDocument instance.
kit-00037-04 00:13:15.143025 [ kit_queue_0002 ] ToMaster-0002 Send: error: cmd=load kind=faileddocloading
e[kit-00037-02 00:13:15.143214 [ kit_callback ] CallbackWorker::callback [ToMaster-0002]: STATUS_INDICATOR_START [(nil)].
kit-00037-02 00:13:15.143278 [ kit_callback ] ToMaster-0002 Send: statusindicatorstart:
37mwsd-00023-03 00:13:16.582532 [ prison_ws_0002 ] ToPrisoner-0002 Recv: error: cmd=load kind=faileddocloading
wsd-00023-03 00:13:16.583010 [ prison_ws_0002 ] ToPrisoner-0002: handling [error: cmd=load kind=faileddocloading].
wsd-00023-03 00:13:16.583054 [ prison_ws_0002 ] ToPrisoner-0002 -> ToClient-0002: error: cmd=load kind=faileddocloading
wsd-00023-03 00:13:16.583095 [ prison_ws_0002 ] ToClient-0002 Send: 37 bytes
kit-00037-04 00:13:15.144277 [ kit_queue_0002 ] Socket handler flagged for finishing.
kit-00037-04 00:13:15.144329 [ kit_queue_0002 ] Thread finished.
[…]
kit-00037-00 00:13:15.179175 [ loolkit ] Termination flagged. Finishing.
kit-00037-00 00:13:15.179248 [ loolkit ] SocketProcessor finishing. TerminationFlag: 1, n: 83, payload size: 0, flags: 81
kit-00037-00 00:13:15.179285 [ loolkit ] SocketProcessor finished.
kit-00037-00 00:13:15.179322 [ loolkit ] Removing '/lo’
kit-00037-00 00:13:15.315182 [ loolkit ] Removing '/user/docs/'
wsd-00023-00 00:13:16.755676 [ prison_ws ] SocketProcessor: exception: Connection reset by peer
wsd-00023-00 00:13:16.755746 [ prison_ws ] SocketProcessor finished.

In the browser, I see the text modification tools on top but below it says “Connecting…”, the wheel symbol keeps spinning and no document is ever loaded.

In Comment #38, pupaxxo wrote that he had patched apps/richdocuments/controller/documentcontroller.php to remove ?encoding=text from $token, but contrary to Nemskiller that didn’t change anything for me.

I’m running Nextcloud 10.0.0 with updated Richdocuments app (1.1.6) and latest Collabora Online Docker image and followed the tutorial from Collabora Online in Nextcloud.

Any suggestions how to go on?

1 Like

Hi Mejo,

thanks for the suggestion. I already had escaped even in the form of -e “domain=www\.domain\.tld” and your hint made me think it was maybe too much, so I removed the “” escaping. But unfortunately still no go :expressionless: 1.1.6 app used.

I hope we’ll find a solution.

regards

Hi Mike, your escaping in the domain name were right. I didn’t check the result of my post, apparently backslashes need to be escaped when writing here :slight_smile: Fixed my reply now.

Where exactly do you get your ‘unexpected connection error’? Is it a log from dockerized Collabora Online or do you see it in the Nextcloud webinterface? Did you check the Collabora logs? You can do so by running docker logs -f <container-id>. If the Nextcloud Richtdocuments App connects to your Collabora Online instance at all, you’ll see corresponding logs there. If no logs appear while trying to connect, then Nextcloud doesn’t access Collabora Online at all.

Yeah @mejo , I know, I saw the missing escaping in my preview :wink:

I checked the logs again, and I again realize there must be something wrong with my Proxy settings for WS.

Log entries:
wsd-00024-04 00:00:52.801183 [ client_ws_0001 ] ClientRequestHandler::handleRequest: BadRequestException: Invalid URI or access denied.

wsd-00024-04 00:00:52.801237 [ client_ws_0001 ] Thread finished.

I really don’t know what I’m doing - I’m looking at my apache virtual host (NameVirtualHost) configuration for office.domain.tld:443 and intuitively don’t understand a single thing about those ProxyPass rules. Ports are correct, SSL Cert Let’s encryp activated etc.

Anyway - did you manage to solve the problem on your side?

edit: “Connection error try again” comes in the webui

Hi @MikeLupe, I’m still stuck with the issue described in comment comment #177. But at least it seems like I got further than you so far :slight_smile: My VirtualHost configuration is basically the one from the official documentation. I have Nextcloud at vhost-name.example.org and Collabora Online at office.vhost-name.example.org. Maybe you should describe your setup and VirtualHost configuration somewhere in detail (e.g. in a pastebin) in order to make it more comprehensible. I then could compare it to my setup and tell you about the differences.

@mejo I didn’t place the SSLCipherSuite in the .conf file, so maybe (almost for sure) there lies the problem.

Anyway, I got another problem now with my apache, so I’ll try to do some investigation. I hope to soon be able to catch up with you :slight_smile:

@MikeLupe why don’t you use the LetsEncrypt include file in your VirtualHost config? Like here:

<VirtualHost *:443>
        [...]
        # Include letsencrypt SSL configuration defaults
        Include /etc/letsencrypt/options-ssl-apache.conf

        #   SSL Engine Switch:
        SSLEngine on
        SSLCertificateFile    /etc/letsencrypt/live/office.test-vm.example.org/fullchain.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/office.test-vm.example.org/privkey.pem
</VirtualHost>

Great idea @mejo , thanks! One can see I’m not that used to apache config…

Still same error. Not yet there, but getting closer (I guess) :slight_smile:

@MikeLupe
make sure to enable the ws proxy module for the apache.
eg
a2enmod proxy_wstunnel

@fabian thanks, it already is enabled.

also make sure you haven’t restricted the app to any groups, as soon as you do it fails…

it works on new documents for me now, but when opening existing documents I get no error, it just gets stuck on connecting…

@dagnotland I haven’t restricted the app for my user, thanks for the hint.

The funny thing is: When I create a new document, I get the error message in English: “We are sorry, this is an unexpected connection error. Please try again.”

When trying to open a document, it’s in German: “Ein unerwarteter Verbindungsfehler ist aufgetreten. Bitte versuchen Sie es erneut.”

That’s quite cool, isn’t it?

@bottom of page on left side it says, viewing or view.

try to click that area/box when it’s loading and see if it helps.

Same error message. As I open a document it’s in German :wink:

edit: btw it’s bottom right side “Ansicht”, that’s what you meant, didn’t you?