Internal server error when trying to login

That’s indeed unfortunate.

It seems a configuration is written into the user directory which is not considered during the upgrade. :frowning:

Is there still a known issue when upgrading a nextcloud docker installation from v19 to v20?

I have exact the same issue, described above:
Today I upgraded from Nexcloud v18 to v19-05: everything went fine (just changed the docker-compose.yml)
Then I tried upgrading from v19 to c20, but this didn’t work: I got an ‘Internal Server Error’
Fortunately, du to a BTRFS snapshot I could go back to v19.

Is there any solution for my next upgrade?

Regrads,
Frank

Hi @ncuser2018, no fix that I know of. I ended up starting over with 20.0. It worked for a while, but I am now facing an issue where I can no longer log into the WebUI from any account. I enter my credentials and hit Log In and then it just refreshes the login screen and produces no errors nor output of any kind.

@all, Another dead end thread? say it isn’t so. I have had 10 unique critical problems with nextcloud in as many days and all have had dead-end threads.