Internal server error when opening settings/admin/serverinfo

restart server maybe?

The reason this is happening: is down so serverinfo runs into a timeout while trying to figure out if updates for apps are available.



Nope. Restarting the server didn’t help either :confused:

I can reach ,but serverinfo still doesn’t load.
Though I have to admit, that it is really slow!

can you reach

Yes of course I can reach my own server

hmm, then I am out, sorry

We should keep things clear: is preventing your serverinfo, ocs api and apps page from loading, everything else should work perfectly fine. As long thats the case for you i dont think there is anything we can do till the services are back to work again.

according to my monitor system (using the ocs api page) i see downtime /degraded state since a few hours with some recovery, sadly not for too long: timedata is UTC+1 grafik

1 Like

I see. Thanks for the information and your help!

1 Like

If your error persists after recovery of the services you can try to deactivate your apps one by one to see if you can reach the serverinfo page again. I had different errors during downtime so there might be another problem around.

Edit: regarding the appinfo / bootstrap error it could be the notes app: "Could not decrypt key" upon login

I just disabled all my apps, but I still can not open serverinfo.
I guess services are still not fully recovered.

Do you see any further errors in your Nextcloud log or your webserver / php logs? Looks like there is something else going on because i have no further delays here using serverinfo.

This is what I see in my nginx access log: - - [11/Oct/2020:00:10:38 +0200] "GET /settings/admin/serverinfo HTTP/2.0" 500 4927 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:81.0) Gecko/20100101 Firefox/81.0"

In my nginx error.log as well es in my php-fpm.log is nothing suspicious.

I found this in my nextcloud log:

[PHP] Error: Error: Undefined offset: 0 at /usr/local/www/nextcloud/apps-pkg/serverinfo/lib/OperatingSystems/FreeBSD.php#188 at <<closure>>

 0. /usr/local/www/nextcloud/apps-pkg/serverinfo/lib/OperatingSystems/FreeBSD.php line 188
    OC\Log\ErrorHandler::onError(8, "Undefined offset: 0", "/usr/local/www/ ... p", 188, {result: [{inter ... ]})
 1. /usr/local/www/nextcloud/apps-pkg/serverinfo/lib/Os.php line 132
 2. /usr/local/www/nextcloud/apps-pkg/serverinfo/lib/Settings/AdminSettings.php line 111
 3. /usr/local/www/nextcloud/apps-pkg/settings/lib/Controller/CommonSettingsTrait.php line 141
 4. /usr/local/www/nextcloud/apps-pkg/settings/lib/Controller/AdminSettingsController.php line 83
    OCA\Settings\Controller\AdminSettingsController->formatSettings([[OCA\ServerInfo ... ]])
 5. /usr/local/www/nextcloud/apps-pkg/settings/lib/Controller/CommonSettingsTrait.php line 152
 6. /usr/local/www/nextcloud/apps-pkg/settings/lib/Controller/AdminSettingsController.php line 68
    OCA\Settings\Controller\AdminSettingsController->getIndexResponse("admin", "serverinfo")
 7. /usr/local/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 169
 8. /usr/local/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 100
    OC\AppFramework\Http\Dispatcher->executeController(OCA\Settings\Con ... {}, "index")
 9. /usr/local/www/nextcloud/lib/private/AppFramework/App.php line 152
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\Settings\Con ... {}, "index")
10. /usr/local/www/nextcloud/lib/private/Route/Router.php line 308
    OC\AppFramework\App::main("OCA\\Settings\\ ... r", "index", OC\AppFramework\ ... {}, {section: "serve ... "})
11. /usr/local/www/nextcloud/lib/base.php line 1009
12. /usr/local/www/nextcloud/index.php line 37

GET /settings/admin/serverinfo
from by ad at 2020-10-10T22:22:02+00:00

I’m not really familiar with freebsd, perhaps someone else has a better understanding of whats going on. It looks like a php error but could be related to something else. Did you change anything lately?

I upgraded php from v7.4.10 to v7.4.11.
I already tried downgrading it back to v7.4.10, but this did also not solve the issue.
So I’m not sure what is causing the problem.

I’m starting to speculate.
Maybe serverinfo on NC20 is not yet compatible with FreeBSD?

Perhaps you can try to execute the occ command.
It should be something like this in FreeBSD “su -m www php /path/to/nextcloud/occ” and use the “maintenance:repair” and “integrity:check-core” to see if the nextcloud files got a problem.
Its only a guess

I already tried that :slightly_frowning_face:

As well as:
su -m www -c "/usr/local/bin/php -f /usr/local/www/nextcloud/occ integrity:check-app serverinfo"

Seems like I am not the only one.

This issue should get fixed with NC v20.0.1.