Internal Server Error after Upgrade to Nextcloud 15

/tmp created and set ownership as advised.
The new log is here.

As soon as I try to access the nextcloud, the log explodes.

" No such file or directory", maybe you removed some files or have file corruption? maybe look for specific Nextcloud help, or restore a backup :expressionless:

OK, I restored the backup via the ncp.
The NextCloud GUI is back.

Instead of updating the nc calenders with the clients data which is more up-to date it restored the clients. Happened to my Outlook calendar :weary:
I still have the mobile calender not synced and immediately stopped the sync until i have figured out how to replicate it to the cloud instead the other way round.
Shouldnt’t the restore script take care of so this doesn’t happen?
At least there should be a warning about this fact…

In addition to that, the files that I had synced from my mobile were not restored.

restore files...
restore database...
no datadir found in backup
Maintenance mode disabled 

Well, as things went down the drain already I thought I try to update once again to the latest version, but…

[ nc-update-nextcloud ]
BTRFS not supported


Would you please advise how to start over with this thing?
Uninstall? How?
Reinstall using the curl installer?

tried this

try with version: 15.0.4

15.0.4 worked.
Now, I can’t sync my calender data from the mobile to the empty NC15 calendar.
It will just sync from NC to mobile and delete the calendar entries…what a mess.
Contacts won’t sync at all. Probably better like this, else they also get deleted. :man_facepalming:

I imagine you had a dataless backup, right?

yes, if you have BTRFS as your rootfs, the update app has not been adapted to that yet. You will have to do the regular Nextcloud update

I used the backup that was made during the update process.
Considering the time it took, it should contain data.
I could unpack the tar and see what’s inside, but it’s not that important because I still have the original files on my mobile.

that backup is without data

I Have the same problem again. I Updated to the latest Nextcloudpi 1.10.7 and after that updated nextcloud from the NCPi Panel from 15.0 to 15.0.5. Now again i get the Internal Server error.

When i look at the System Info page Nextcloud Check and MariaDB Service show “Error”

Any new ideas besides getting stuck on old versions?