Ihr Datenverzeichnis ist ungültig. Stellen Sie sicher, dass eine Datei ".ocdata" im Wurzelverzeichnis des data-Verzeichnisses existiert

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.4): 20.0.4
Operating system and version (eg, Ubuntu 20.04):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1): 7.4.13

The issue you are facing: Unter " Sicherheits- & Einrichtungswarnungen" erscheint die Fehlermeldung “Ihr Datenverzeichnis ist ungültig. Stellen Sie sicher, dass eine Datei “.ocdata” im Wurzelverzeichnis des data-Verzeichnisses existiert.”. Aber die Datei .ocdata existiert im Ordner data!

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Einstellungen
  2. Verwaltung Übersicht
  3. Sicherheits- & Einrichtungswarnungen

The output of your Nextcloud log in Admin > Logging:




The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'cloud.xxx.ch',
  ),
  'datadirectory' => '/home/httpd/vhosts/xxx.ch/cloud/data',
  'dbtype' => 'mysql',
  'version' => '20.0.4.0',
  'overwrite.cli.url' => 'http://cloud.xxx.ch',
  'dbname' => 'xxx',
  'dbhost' => '127.0.0.1:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
  'onlyoffice' => 
  array (
    'verify_peer_off' => true,
  ),
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'updater.release.channel' => 'stable',
);

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Wem gehört sie, wie sind die Zugriffsrechte gesetzt?

Zugriffsrechte = 0644
Besitzer/Gruppe = stimmt mit allen anderen Elementen überein!
Nextcloud_data_ocdata|690x266

Bei mir hat die Datei eine Größe von Null. Bei Dir steht eins. Kannst Du das noch anpassen?

btw. hast Du schon die Suchfunktion dieses Forums verwendet?
Das Thema wurde schon oft besprochen.

Lies mal:

Die Dateigrösse 0 brachte die Fehlermeldung nicht zum Verschwinden. Geholfen hat schlussendlich das da:

It’s strange, but It helps me. I klicked Basic Settings clicked Webcron, and after that back to Ajax. This message gone.

Obwohl es tatsächlich ein bisschen «strange» tönt.
Besten Dank für die Hilfe!

1 Like