HowTo: Install Onlineoffice on Ubuntu/Debian (No Docker No Limitation)

Sorry , but I don’t know. Can you please try it and let as know if it works?

Sure I will try.

1 Like

what does the script have to do with nginx, apache or any proxy???

Since the CODE 2.0 release for Docker there are proxy problems when using nginx instead of apache. There was released updated configuration for apache but the ones for nginx doesn’t work (released here). The important apache lines that noone seems to know how to write in nginx are:
ProxyPass /lool/ws wss://
should be replaced by
ProxyPassMatch "/lool/(.*)/ws$" wss://$1/ws nocanon
# Encoded slashes need to be allowed
AllowEncodedSlashes NoDecode

And I thought that avoiding Docker would possibly solve the problem but idk.

Yes, i am using it with nginx,

That’s great! Then I’m hopeful. It’s compiling right now. Thanks for sharing your script.

My libreoffice (core) build fails :confused: Here’s my build log: any help appreciated.

cant get it working,
do i need collabora online app
do i need collabora container
do i need docker
Please guide

did you get it working?

There are cross-compilation notes for LibreOffice Core and maybe you can modify the script by changing the configure or make flags:

The LibreOffice/online doesn’t have much info and the INSTALL doc just says “lets as an exercise for the reader”.
It takes me to niginx error page
When entering https
It takes me to my nextcloud page asking me to add
… to trusted domain.
Is this the way it should do.
Please guide

I can’t compile either. Im about to try with a specific commit now though.
This person reported that building lool with:

(The master branch at: commit 2757adc3c69ce345a9ba8a82166d75665b7e1ef1 compiles fine.)

(the link seems to be the basis for the presented script here also)

Why does your script install the apache2 package?

error in my nextccloud when i click on any doc file in nextcloud

fclose() expects parameter 1 to be resource, boolean given at /var/www/nextcloud/lib/private/Files/Storage/Local.php#218
fread() expects parameter 1 to be resource, boolean given at /var/www/nextcloud/lib/private/Files/Storage/Local.php#217
fopen(/var/next/nextcloud/data/appdata_oca7icpmuxev/theming/4/icon-core-filetypes_x-office-document.svg): failed to open stream: No such file or directory at /var/www/nextcloud/lib/private/Files/Storage/Local.php#216
filesize(): stat failed for /var/next/nextcloud/data/appdata_oca7icpmuxev/theming/4/icon-core-filetypes_x-office-document.svg at /var/www/nextcloud/lib/private/Files/Storage/Local.php#211

Because I use it as proxy with lool.

I see, that makes sense… Would it be also possible to use nginx instead of apache2? and is it possible to have loolwsd listening directly on port 443 instead of 9980?

Yes, you can use nginx instead Apache2. You can change loolwsd port if you add (–o:port=xxyy) to your /lib/systemd/system/loolwsd.service. it can not be port 9981.
But it is highly recommended to use Apache or nginx because the lool ssl is very poor. (SSL Lab will grade it to F or T)

Thanks for the tip regarding the poor SSL implementation of loolwsd. I am now using HA-proxy just like you recommend and it works nicely, thanks for your script I was looking for something like that!

Will be different config for nginx?
Do we need to specify in nginx?

As per my understanding, You could build LibreOffice online on ARM? I’m very interesting of that, because I could build core part with ease, but stucked with online part: it throws me a hell bunch of integer types mismatch exactly like that guy with Ubuntu 14 above.

I just updated and tested the new script version on Ubuntu 14.04. It works.