How to restore NCP instance after corrupting the SD Card

Backstory (skip to Current Situation for my actual issue :slight_smile: ):
I am using NCP for I think half a year now. A few days ago I decided to try upgrading it to Bullseye and to NC 23 so I tried to back up both the HDD and the sd card. However, my great luck struck me and my sd card got corrupted. All partitions won’t mount and the contents shows “unknown” in the Disks app in Ubuntu.

Current Situation:
My sd card got corrupted and I tried many things to try to recover it but so far no luck and I think I’m about to give up and look at other options. Before corruption, my NCP instance wasn’t in the latest NCP version, still on NC 22 and debian is still on Buster. I have backups of everything, at least as far as I know. I have an export of NCP configuration and I want to believe that I moved the database to my HDD :sweat_smile:

So, what can you advice to me in this situation? I have the original NCP image I used initially. Should I just flash that, import NCP configuration then upgrade my instance? Would that even be enough to get back to where my instance was?
Or should I get the latest Bullseye image with NC23 and flash that? I’m worried that since my previous data was still NC22 and Buster, there would be conflicts and issues.

Thank you very much for those who will help. I’m a bit knowledgeable with stuffs but without NCP, I may not even consider self-hosting because I’m lazy :smile:

I gave up recovering the corrupted SD card :sweat_smile: What I did is the following:

I discovered that there are NCP configurations that had to be triggered or configured again.

  • nc-static-IP
  • namecheapDNS (not sure if all DDNS are affected)

Now I’m back running and upgraded to Bullseye and NC23.

(I had some issues with syncing though because my database backup was a few days older and some files had conflicts)