How can I edit the default ignored files list?


#1

Hi all,
I installed Nextcloud on an x64 server running Arch Linux with nginx, mariadb and php 7.
After trying it out a little I installed the Desktop client on my Mac.
I put some folders in the nextcloud sync folder and then noticed that several files were not synced, like .htaccess files.
I need those files synced, so I tried to edit the list of excluded files but I found a long list of patterns that I can not edit or delete.
Looking in the github repo of the client I found the “sync-exclude.lst” file and I edited it, but I know it will be overwritten with the next update of the client app. Now most of my files get synced.
Why are all those files excluded?
Why are “.htaccess” not synced with an error related to not available space on my server? (other new files get synced regularly)
Thanks,
Matteo


#2

You can locally edit the .snyc-exclude.lst, I’m not really sure that this file is overwritten during an update. So keep a copy and verify the settings after an update.
Most excluded files are temporary files of operating systems or of a specific client software where it makes no sense to sync them over devices.

.htaccess is blacklisted for security reasons:


#3

Sorry for the late reply and thank you very much for your answer :slight_smile:
Anyway, IMHO the user should be able to take decisions over his files.
After all, this is the whole point of this private cloud project, right?
Obviously any technical reason are accepted.
But since I am also the maintainer of my personal cloud server, I’m ok with dealing with the extra work to support some extra file synchronization.
I edited that file a month ago now, and my server and my client seem to work as expected, including the syncing of .htaccess files.
I have peace of mind about this edit because the only issue brought to my attention about this .htaccess files (and all other excluded) is about security when running an apache webserver that would interpret thos htaccess files. Since I use nginx I feel safe.
Am I wrong with this last assumption?


#4

Yes, but to protect data many settings are done in a way that it is secure by default. You can also set apache to ignore .htaccess files, so you could do that for everything within the data-folder. But you need to be able to change the apache-configuration (not possible for users on shared hosting, in some administration tools access to apache-configuration is limited or needs advanced knowledge).

If you want to manage websites via external storages, I would rather try to put this in via feature request, that for such storage types, .htaccess is not ignored.

On nginx, these .htaccess-files are just files and do not alter the configuration.


#5

Hi, where do I find the snyc-exclude.lst ?

Greetings from Germany
JK


#6

Found it in C:\Users\kubik\AppData\Local\Nextcloud but it was empty!?

Where do I find the list where the excluded files are listed?

Greetings


#7

Hi,

In C:\Users%username%\AppData\Local\Nextcloud adds a file named sync-exclude.lst if you add other extensions that not the default ones.

In NextCloud client, in the tab “General” you have “Advanced” - Edit Ignored Files, there are the default ones, if you add anything to there, it will create the sync-exclude.lst file.


#8

Is it possible to edit the default not synced files?
I want to delete .~lock.* from this list because I think it is very useful to sync it.

As I understand I can only add things to the sync-exclude.lst but I cant take stuff away cause it is empty.

I’m on Kubuntu by the way.


#9

Hello

I’ve a simillar issue: I’m using encfs to encrypt files for a specific folder AND their filename. A lot of files are excluded from sync due to a too large default exception rule.

I checked the content of the exlude file “.snyc-exclude.lst” and it’s empty.

How can I change a default exception or remove ALL exceptions for a specific folder ?

Thanks


#10

Hello,
I am experiencing the same issue. And the suggestions didn’t fix it.

I have a lot of unsynced files due to ignored file rules. When I open “edit ignored file list” section it is all grayed out so that I cannot edit. It seems that the sync-exclude.lst file is located in /tmp/.mount_Nextcls92Dx1/usr/bin/ folder, which I don’t have permission to edit and is an odd location to edit anyway.

I am using Nextcloud Desktop Client Version 2.3.3 on Ubuntu 16.04.

Anybody have an idea on how can I change file-name rules for syncing? Editing the rules on the server side also works for me. Thanks.


#11

/etc/Nextcloud/sync-exclude.lst
was the file I needed to edit


#12

Same problem for me; I need htaccess :((((((

the file on mac
/Applications/nextcloud.app/Contents/Resources/sync-exclude.lst

but did not work in my case, blocked server side too