Having trouble accessing my Nextcloud server remotely

Apache reference https://httpd.apache.org/docs/current/mod/directives.html

Nextcloud reference https://docs.nextcloud.com/server/stable/admin_manual/

If your page doesn’t load at all, then it probably isn’t the Nextcloud setup that’s the problem. It’s going to be something else on your system. Apache or your firewall probably.

What do you get from this?

apachectl -t -D DUMP_VHOSTS

This is the output from that command. I used the same conf file and pointed it to an html folder with an index.html file in it and I couldn’t reach that either. I could however reach my other webserver when I changed it to run on port 8080… I just modified its conf file. That just makes me think it’s either an apache conf issue or a Nextcloud conf issue. The port and Nextcloud works just fine when I access the site across port 8080 on my local network.

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' directive globally to suppress this message
VirtualHost configuration:
*:80          (/etc/apache2/sites-enabled/000-default.conf:1)
*:8080                 nc.example.org (/etc/apache2/sites-enabled/nc.example.org.conf:1)

I still can’t get this to work. I have tried several other things. I have changed the port, modified the configuration files but to no avail. I also tried to install Nextcloud via snap but I couldn’t get that to work either. Is there anything else that I should try?

Are there any logs that I can look at that would tell me why this isn’t working?

I stood up a different webserver on a seperate port and it worked just fine. I have used the port 8080 before and it works great. It allows me to access it from outside of my home network and everything. I think Nextcloud isn’t configured correctly to allow the remote traffic. If the issue wasn’t Nextcloud the other tests I ran that worked wouldn’t have worked.

I am not going to do the self install anymore, I am now trying to setup the AIO docker image. I am having trouble with that too though. I just opened a new thread…