[gelöst] Nextcloud mit Ubuntu 20.04 - Oracle VPS Server - The OPcache interned strings buffer is nearly full

Hallo Forum,

warum bekomme ich folgende Meldung:

Security & setup warnings

It’s important for the security and performance of your instance that everything is configured correctly. To help you with that we are doing some automatic checks. Please see the linked documentation for more information.
There are some warnings regarding your setup.

The PHP OPcache module is not properly configured:
    The OPcache interned strings buffer is nearly full. To assure that repeating strings can be effectively cached, it is recommended to apply opcache.interned_strings_buffer to your PHP configuration with a value higher than 8.

Please double check the installation guides :arrow_upper_right:, and check for any errors or warnings in the log.

Check the security of your Nextcloud over our security scan

Die Meldung ist mir bekannt und ich kann das Problem lösen.

Mein System:

####
OS
Canonical-Ubuntu-20.04-2021.12.01-0
####
Operating System: 	Linux 5.11.0-1028-oracle x86_64
CPU: 	AMD EPYC 7551 32-Core Processor (2 cores)
Memory: 	967.00 MB
Server time: 	Mon Feb 14 12:25:54 UTC 2022
Uptime: 	0 hours, 15 minutes, 25 seconds
####
PHP
8.0.15
Memory Limit: 2 GB
Max Execution Time: 3600
Upload max size: 10 GB
####
Database
MariaDB
mysql
10.6.7
2 MB
####

Das System wurde mit dem c-rieger Script installiert.

Warum ist die Meldung in Englisch?

FRAGEZEICHEN! Wenn du das Problem lösen kannst, ist die Frage danach doch ĂŒberflĂŒssig. Wenn du meinst: warum bekomme ich generell diese Art von Fehlermeldungen? Dann wĂ€re die Antwort: weil es offensichtlich Probleme mit deinem Server gibt.

Hallo @JimmyKater ,

erklÀrst Du mir den Sachverhalt, die Forensuche war erfolglos.

Liegt das am Kernel?

Linux 5.11.0-1028-oracle x86_64

Kommt die Meldung von Nextcloud oder vom VPS (Server)?

Kurze knackige richige Antworten finde ich immer gut.

Probleme gibt es mit dem Server nicht, ein Nextcloud Rating von A+ habe ich.
Die Fehlermeldung habe ich abgestellt.

MfG
nc-kay

Siehe dazu, meine Frage hier ist aber nicht gelöst:

opcache ist ein php-modul, das geladen werden kann. Sene Einstellungen, zu denen auch die in der Fehlermeldung bemeckerte zÀhlt, befinden sich in der (jeweils aktiven) php.ini; bei meinem einen Server mit Debian Buster und php7.4-fpm ist das /etc/php/7.4/fpm/php.ini Darin finden sich die aktiuvien opcache-Einstellungen:

grep -i opcache /etc/php/7.4/fpm/php.ini | grep -v ";"
[opcache]
opcache.enable=1
opcache.enable_cli=1
opcache.memory_consumption=512
opcache.interned_strings_buffer=128
opcache.max_accelerated_files=600000
opcache.revalidate_freq=2
opcache.log_verbosity_level=2

Den bemeckerten Wert kannst/soltest du wahrscheinlich wie empfohlen hochsetzen, generell ist es hier aber empfehlenswert, vor einer Änderung einzelner Werte etwas nachzulesen (kopieren aller Werte aus meinem System könnte auch unerwĂŒnschte Effekte haben).
GOOD LUCK!

3 Likes

Danke. :slight_smile:

Kann mir das jemand erklÀren, den Wert habe ich schon verdoppelt (auf 32), jedoch bekomme ich immer noch diese Fehlermeldung:

The PHP OPcache module is not properly configured:
The OPcache interned strings buffer is nearly full. To assure that repeating strings can be effectively cached, it is recommended to apply opcache.interned_strings_buffer to your PHP configuration with a value higher than “16”.

Habe die Version 23.0.2

Seit Wochen das gleiche PhÀnomen. Soll den Speicherwert erhöhen, und nach Neustart und einigen Minuten Nextcloud Nutzung 23.0.2 erscheint die gleiche Fehlermeldung.

3 Likes

Hat hier jemand noch etwas Neues erfahren?
Ich habe hier gelesen dass es wohl mit den installierten Apps skalieren soll, aber ich habe fast nichts auf der Instanz aktiv - und meine Nextcloud ist aus dem offiziellen Docker-Image, den Wert können die Devs nur selbst anpassen. Der Wert wurde ja schon auf 16 angehoben - dennoch bleibt das Problem logischerweise.