Failed to get LoKitDocument instance

Glad you posted as Overlay was posted as a solution to Aufs on Debian and the install looked a bit complex for me.
So don’t think I will try that, so far device-mapper seems to be the easiest and most reliable if you are not on Ubuntu Xenial as I think Aufs + Docker works fine in 16.04+.

Its prob wise for NextCloud to pick a distro, but create a Wiki as if you read the the reasons why about Aufs and lack of kernal support its all a bit political, complex and different across distro’s, so problematic to provide documentation for all.
Ubuntu seems to be happy about Aufs and others are not, some seem to be forwarding Overlay so I guess its a bit confusing.
A wiki that splits into distro’s fed with info from the forum could help much.

Ok, so I investigated a bit more, and I managed to make it working with aufs.

Here is my docker info:

Containers: 7
 Running: 7
 Paused: 0
 Stopped: 0
Images: 6
Server Version: 1.12.2
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 39
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: host bridge overlay null
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options: seccomp
Kernel Version: 4.5.7-docker-4
Operating System: Ubuntu 16.04.1 LTS
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 7.752 GiB
Name: scw-f3c6f1
ID: F2MB:YQQE:AZ3A:WZX3:NSAT:DDSC:KKXD:TWXG:RHWL:ECUR:XGC4:KESG
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:
 provider=scaleway
Insecure Registries:
 127.0.0.0/8

So I’ve found my workaround, but I lost 20h… This is just a workaround for me, I still would prefer to make it working with CoreOS (overlay). Also, I’d like to avoid people getting into troubles with that. I think that the “documentation” should be updated.
I’m wondering where we can PR for that matter?

I just opened an issue at:

Please add your docker info there also to help target the issue.

Good idea, posted.

I changed the driver to overlay2 and then it worked.
My Cloud is running on a kvm debian 9 server.

I followed the instruction on the docker website.

#4 was the key part

Edit /etc/docker/daemon.json. If it does not yet exist, create it. Assuming that the file was empty, add the following contents.
{
“storage-driver”: “overlay2”
}

@ bcooksley This is the best answer for now! I’ve the same “failed to load…”-error.

For me worked this simple solution:

docker run --name lool -t -p 0.0.0.0:9980:9980 -e “domain=223\.254\.253\.108” -e “username=admin” -e “password=S3cRet” --cap-add MKNOD collabora/code
docker stop lool
docker start lool

thats it; thx