Error during first install for a linux beginner

Hi all,

I’ve discovered Nextcloud very recently and would like to test it first on a virtual machine running on Ubuntu 16.04.1 (desktop version).
But last time I used linux was 15 years ago. I’ve tried to follow the installation guide but I’ve always got an error with MariaDB configuration.
For example, with the installation wizard, I get this error:
Error while trying to create admin user: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000][1698] Access denied for user 'root'@'localhost'

I’ve used the following entries:
Username: skycorp
Password: skycorp_password
Database user: root
Database password: root_password (for example, since no password was defined before)
Database name: nextcloud
Database host: localhost

I’ve looked through Internet and found several topics related to similar problems, but I haven’t found a clear and simple way to solve it. It works with SQLite, which doesn’t request database info, but not with MySQL/MariaDB.
After 2 days of unsuccessful tries, I hope someone here will give me some hints to properly install nextcloud.

Thank you in advance.

I did the following to setup MariaDB before using the installation wizard:

sudo mysql_secure_installation
# answer yes to all questions

sudo mysql -u root -p
	create database nextcloud;
	create user nxtcloudadmin@localhost identified by 'admin123';
	grant all privileges on nextcloud.* to nxtcloudadmin@localhost identified by 'admin123';
	flush privileges;
sudo nano /etc/mysql/my.cnf
# add these lines at the bottom:
	log-bin = /var/log/mysql/mariadb-bin
	log-bin-index = /var/log/mysql/mariadb-bin.index
	binlog_format = mixed
sudo service mysql reload

Then try the wizard again where you use:
Username: skycorp
Password: skycorp_password
Database user: nxtcloudadmin
Database password: admin123
Database name: nextcloud
Database host: localhost

And don’t forget to change admin123 into a real password.

Good luck!


That works!
I’ve just added sudo before each command line:
sudo mysql_secure_installation
sudo mysql -u root -p

I’m not very familiar with nano. It works, but not so easy to manipulate.
For beginners, I would recommand gedit, but it’s just my personnal opinion :wink:

Thanks a lot

Good to hear it worked. I added the sudo commands to the post.

Which text editor to use is a topic of much discussion. I prefer to write a script and automate these configurations with commands like cat and sed.

That’s true, it would really be faster and painless with a script.

I now continue to follow the guide here:, there is a section php.ini Configuration Notes.
I’ve found php.ini files in these folders: /etc/php/7.0/apache2/ and /etc/php/7.0/cli/, but except for the date/time configuration settings, I’ve no idea what should be modified (and both files are quite long). And, do I have to remove the ; at the beginning of these lines?

In a previous section, called Pretty URLs, it is referred to a config.php file, but I haven’t found it yet. Where is it supposed to be located?

But i am having a same problem can you please help me with a details how to configure with it!!
while i was creating my own webpage localhost server it shows= Failed to connect to your database server. The server reports the following message: . SQLSTATE[HY000] [1698] Access denied for user ‘root’@‘localhost’ .

please help me ! I hope you will give me some hints.