Error after upgrading app

Use your backup.

Otherwise you can manually install the v6.0 of OnlyOffice app.
Get it from Releases · ONLYOFFICE/onlyoffice-nextcloud · GitHub

I have the same issue, the only way to get OO working again is to restore a backup of my appdata.

I created a post on OnlyOffice forum about this, which you can follow here.

Same here: Different servers, same error:

The “documentType” parameter for the config object is invalid. Please correct it.

Nextcloud 22.2,
Own OnlyOffice Document Server running. Was working fine before. https://pixeloffice.net/

Thank you for any help !
p.s. how can I simply re-role to the previous version of the app ?

Under unraid you can use the CA Appdata Backup/Restore App.

I have fixed this by manally downgrading the app version to 7.1.2.

These were the steps taken:

NOTE: The instructions below are for the non-docker installation of Nextcloud on a debian based server with NginX. If you have a different web server, check who owns the current folders and files in your NC root folder and change the www-data below accordingly.

  1. Disable and remove the OnlyOffice app from the Nextcloud web UI.

  2. Open your CLI, ssh to server where your NextCloud is hosted and go to the apps folder (cd <path to your NC>/apps)

  3. Download the previous version of the OnlyOffice app:

sudo -u www-data wget https://github.com/ONLYOFFICE/onlyoffice-nextcloud/releases/download/v7.1.2/onlyoffice.tar.gz

  1. Unpack the archive:

sudo -u www-data tar xvf onlyoffice.tar.gz

  1. Fix the access permissions of the underlying files and folders:

sudo -u www-data find ./onlyoffice -type d -exec chmod 0750 {} \;
sudo -u www-data find ./onlyoffice -type f -exec chmod 0640 {} \;

Open the Disabled apps list in your NextCloud web UI (reload the page if it was already open) and you’ll see the OnlyOffice app which should be enabled. There’s also the “Update to 7.2.0” button which you now know you shouldn’t click :slight_smile: You’ll now be able to access the OnlyOffice settings (mine were remembered from earlier).

And that’s it… OnlyOffice will work again.

5 Likes

Thank you, @illuminated ! However, this is not working for servers without Sudo / root access. I tried to manually change the files in the /apps/folder but still having the same issue.
Thank you

What version of OnlyOffice is in use? All versions up to 6.0 aren’t supported anymore. Maybe an update of the OO-docker would do the trick?

Not sure how I’d approach the non-root/non-sudo ssh access. If you’re using a hosting account, maybe you have a web file browser that will let you do the listed operations through it?

Had the same problem. After updating the documentserver itself the problem was solved.

cheers

Hello any solution for docker on unraid ?

1 Like

I got it to work with UnRAID. You open a console window to the UnRAID server (not the Nextcloud container).

The key is to replace ‘www-data’ with ‘root’ for UnRAID as there is no www-data user on UnRAID.

You will have to refresh the App’s screen in Nextcloud for the 7.1.2 version of Only Office to show up after you replace everything.

Thank you very much @illuminated!!

2 Likes

can you elaborate more on Unraid with step by steps. I am using Siwat2545 docker’s template for " onlyoffice/documentserver" but for the longest time I had to set it to version 6.0 to work.

Recently I updated my nextcloud ONLYOFFICE app to 7.2.0 and the received the “documentType parameter” error. My Unraid onlyoffice server is still 6.0. So if I use :latest on the docker pull it won’t work at all. Any help is appreciated sounds like you have it working. If I get it working I’ll post a write up on unraid.net

@bigbangus

ETA: I modified the @illuminated instructions to work for UnRAID.

  1. Disable and remove the OnlyOffice app from the Nextcloud web UI.

  2. Open the UnRAID terminal using the >_ button in the top right part of the UnRAID interface.
    2a. Navigate to the Nextcloud directory by typing (change the bolded nextcloud value to the name of the docker container):
    cd /mnt/user/appdata/nextcloud/www/nextcloud/apps/

  3. Download the previous version of the OnlyOffice by typing:
    sudo -u root wget https://github.com/ONLYOFFICE/onlyoffice-nextcloud/releases/download/v7.1.2/onlyoffice.tar.gz

  4. Unpack the archive:
    sudo -u root tar xvf onlyoffice.tar.gz

  5. Fix the access permissions of the underlying files and folders:
    sudo -u root find ./onlyoffice -type d -exec chmod 0750 {} ;
    sudo -u root find ./onlyoffice -type f -exec chmod 0640 {} ;

Open the Disabled apps list in your NextCloud web UI (reload the page if it was already open) and you’ll see the OnlyOffice app which should be enabled. There’s also the “Update to 7.2.0” button which you now know you shouldn’t click. You’ll now be able to access the OnlyOffice settings (mine were remembered from earlier)

1 Like

That did the trick for me. I found, that I was using the OO docker from chvb, which is version 5.5.0.165. After changing to the docker from Siwat2545’s Repository, I can upgrade OO to version 7.2.0 within NC without any issues. I use unraid 6.9.2, NC 22.2.0 stable and OO document server docker 6.4.

How do you find the version of OO in the docker? I’ve been searching for the command but can’t find it.

ETA: I’m an idiot. It’s the little i in a circle on the left side of the Only Office window…duh.

I installed the Siwat2545 OnlyOfficeDocumentServer docker in UnRAID and upgraded to 7.2.0 and everything is working.

7.2.0 works for me too now! Thanks.

Curious what proxy-conf you’re using in swag? Mine is the default but I had to change from http/80 to https/443 in the location/

I’m also using swag.

Nextcloud, OnlyOffice, and Swag are all on the “bridge” network.

In OnlyOffice 80=9080 and 443=4430

Here’s my onlyoffice.subdomain.conf contents:

server {
listen 443 ssl;
listen [::]:443 ssl;

server_name onlyoffice.*;

include /config/nginx/ssl.conf;

client_max_body_size 0;

location / {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_onlyoffice OnlyOfficeDocumentServer;
    proxy_max_temp_file_size 2048m;
    proxy_pass http://192.168.5.40:9080;
}

}

1 Like

With the fixing of the access permissions to the underlying files and folders.
with
sudo -u root find ./onlyoffice -type d -exec chmod 0750 {} ;
sudo -u root find ./onlyoffice -type f -exec chmod 0640 {} ;

where should I be running these…
when I tried to run them in the unraid terminal at the below file level
/mnt/user/appdata/nextcloud/www/nextcloud/apps

I get the error → find: missing argument to `-exec’

thanks in advance

It worked for me, thanks!!!

1 Like

Thank you for this fix. Everything worked, except step 5. OnlyOffice is already working, so not sure if step 5 is necessary?

find: missing argument to `-exec’

Any ideas?

Edit:
tagging @Aceriz1 in case you didn’t already find a solution :wink:
found a post in this topic with the right commands: https://forums.unraid.net/topic/47872-support-dvblink-kerio-connect-apache-php-tvhproxy-webgrabplus/page/8/?tab=comments#comment-1062341

find ./onlyoffice -type d -exec chmod 0750 {} ;
find ./onlyoffice -type f -exec chmod 0640 {} ;

EDIT2:
Somehow the backslash sign gets removed??
In the commands above it ends with a “backslash” and then a “;”