Does anyone have a working nextcloud server?

Ok. I think your nextcloud uses the user “www-data” and the group “www-data”.
Where is your data-dir?
If you can not change to “nextcloud” change to root:
sudo -s

After reinstalling everything and granting permissions before launching the user panel, errors still appear:

sudo chown -R www-data:www-data /var/www/nextcloud

First one:

[index] Error: OCP\Files\NotPermittedException: Could not create folder at <>

  1. /var/www/nextcloud/lib/private/Files/AppData/AppData.php line 157
  2. /var/www/nextcloud/lib/private/Template/IconsCacher.php line 90
  3. <>
    OC\Template\IconsCacher->__construct(OC\Log {}, OC\Files\AppData\Factory {}, OC\URLGenerator {}, OC\AppFramework\Utility\TimeFactory {})
  4. /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php line 84
    ReflectionClass->newInstanceArgs([OC\Log {},OC\Fi … }])
  5. /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php line 101
    OC\AppFramework\Utility\SimpleContainer->buildClass(ReflectionClass … "})
  6. /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php line 116
  7. /var/www/nextcloud/lib/private/ServerContainer.php line 149
    OC\AppFramework\Utility\SimpleContainer->query(“OC\Template\IconsCacher”, true)
  8. /var/www/nextcloud/lib/private/Server.php line 1143
  9. /var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php line 118
    OC\Server->OC{closure}("*** sensitive parameters replaced ***")
  10. /var/www/nextcloud/lib/private/ServerContainer.php line 124
  11. /var/www/nextcloud/lib/private/AppFramework/DependencyInjection/DIContainer.php line 388
    OC\ServerContainer->query(“OC\Template\SCSSCacher”, true)
  12. /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php line 71
    OC\AppFramework\DependencyInjection\DIContainer->query(“OC\Template\SCSSCacher”, true)
  13. /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php line 101
    OC\AppFramework\Utility\SimpleContainer->buildClass(ReflectionClass … "})
  14. /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php line 116
    OC\AppFramework\Utility\SimpleContainer->resolve(“OCA\Theming\C … r”)
  15. /var/www/nextcloud/lib/private/AppFramework/DependencyInjection/DIContainer.php line 414
    OC\AppFramework\Utility\SimpleContainer->query(“OCA\Theming\C … r”)
  16. /var/www/nextcloud/lib/private/AppFramework/DependencyInjection/DIContainer.php line 385
    OC\AppFramework\DependencyInjection\DIContainer->queryNoFallback(“OCA\Theming\C … r”)
  17. /var/www/nextcloud/lib/private/AppFramework/App.php line 124
    OC\AppFramework\DependencyInjection\DIContainer->query(“OCA\Theming\C … r”)
  18. /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    OC\AppFramework\App::main(“OCA\Theming\C … r”, “getImage”, OC\AppFramework\ … {}, {key: “logo”,_ro … "})
  19. <>
    OC\AppFramework\Routing\RouteActionHandler->__invoke({key: “logo”,_ro … "})
  20. /var/www/nextcloud/lib/private/Route/Router.php line 297
    call_user_func(OC\AppFramework\ … {}, {key: “logo”,_ro … "})
  21. /var/www/nextcloud/lib/base.php line 1012
  22. /var/www/nextcloud/index.php line 37

GET /index.php/apps/theming/image/logo?v=0&useSvg=1
from myip at 2020-11-19T16:01:32+00:00

/var/www/nextcloud is your data-dir?

Probably yes:

pi@nextcloudpi:/var/www $ ls -all
total 28
drwxr-xr-x 7 root root 4096 Sep 5 17:33 .
drwxr-xr-x 12 root root 4096 Feb 13 2020 …
drwxr-xr-x 2 root root 4096 Sep 5 17:07 html
drwxr-xr-x 8 root root 4096 Sep 5 17:33 ncp-app
drwxr-xr-x 6 www-data www-data 4096 Sep 5 17:33 ncp-previewgenerator
drwxrwx— 8 www-data www-data 4096 Nov 19 15:45 ncp-web
drwxr-x— 14 www-data www-data 4096 Nov 19 15:48 nextcloud

And again: Please post details for data-dir in config/config.php and the “ls -al” of the corresponding directory.

root@nextcloudpi:/var/www/nextcloud/config# ls -all
total 72
drwxr-x---  2 www-data www-data  4096 Nov 19 15:41 .
drwxr-x--- 14 www-data www-data  4096 Nov 19 15:48 ..
-rw-r-----  1 www-data www-data     0 Aug 26 18:50 CAN_INSTALL
-rw-r-----  1 www-data www-data  1559 Nov 19 16:17 config.php
-rw-r-----  1 www-data www-data 56080 Aug 26 18:50 config.sample.php
-rw-r-----  1 www-data www-data   495 Aug 26 18:50 .htaccess

$CONFIG = array (
  'passwordsalt' => ‚some code,
  'secret' => ‚some’ code 2,
  'trusted_domains' => 
  array (
    0 => 'localhost',
    5 => 'nextcloudpi.local',
    7 => 'nextcloudpi',
    8 => 'nextcloudpi.lan',
    11 => ‚my public ip,
    1 => '',
    12 => ‚',
    3 => ‚',
    2 => ‚',
  'datadirectory' => '/media/myCloudDrive/ncdata',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'ncadmin',
  'dbpassword' => ‚some ‚code 3,
  'installed' => true,
  'instanceid' => 'ochgelgsh5v1',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
    'password' => ‚some ‚code 4,
  'tempdirectory' => '/media/myCloudDrive/ncdata/tmp',
  'mail_smtpmode' => 'sendmail',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'admin',
  'mail_domain' => '',
  'preview_max_x' => '2048',
  'preview_max_y' => '2048',
  'jpeg_quality' => '60',
  'overwriteprotocol' => 'https',
  'loglevel' => '2',
  'log_type' => 'file',
  'maintenance' => false,
  'logfile' => '/media/myCloudDrive/ncdata/nextcloud.log',

Your data-dir is /media/myCloudDrive/ncdata and not /var/www/nextcloud

I have reinstalled the system 20 more times. Trying different solutions to diagnose the problem.
First, the setup wizard is one big bug. It configuring usb hdd and ddns with errors.
When I don’t use the wizard, I don’t configure ddns (I already have a no-ip ban) then I don’t have any errors.

First errors appear when I use the autoboot option for a USB and restart the system.

I fully understand you are little upset of the errors you hit. but please don’t forget you are running software you get for free and seeking free support. I don’t think somebody is willing to help if you tell them their job is “one big bug”.

Chances are high you get help if you post your errors one by one with all necessary details - and wait for somebody to help. me personally couldn’t really help - I run NC on Qnap NAS with docker successfully and it was running pretty fast with basics after following docker guides and videos. I made at least a dozen installations for fine tuning but this is my personal problem…

Reinstalling the system MAY be a solution, but if it doesn’t help there is no reason to do it 20 times, it’s better to spend time analyzing the problem.


Thanks all for your time.

After many hours wasted, I’m at the point where I started.
I decide to leave it as is and not waste any more time on OpenSource. Tried exactly one week, started before last weekend.
Maybe your clouds are working fine, maybe your devices don’t have such a bug console. Maybe I shouldn’t be looking there, since everything works.
Now let someone write under the article about synology that “I have a nextcloud and it’s ok” then I will destroy such a person with an orgasm in my head.
Have fun searching for bugs. (No offense) I have better jobs.
If you ever throw a COMPLETE tutoral how to do it, call me.
Don’t let your work go to waste, let people use it too, since it’s free.

I have found one: czsz.

1 Like

No errors without ddns? Maybe check the syntax of your config file, the ddns entries in the trusted_domains array look like the , should be ’ …

@czsz i consider it understandable to lose your mind about the repeating problems you face trying to install NCP to your RPi (you really DO try to install it on a Raspberry Pi, yes? Which model? And I’m asking that because I read something about Synology and wasn’t sure what you meant by that)

But at the same time, there are 10s of thousands instances running more or less flawlessly using NCP. And the documentation at is pretty clear on how to set it up correctly.

So most probably the problem you’re facing is on your side (i’m not saying it is you!). It could be a defect hardware-part or an unclear envorinment or whatever.

Meaning to have at least a fair chance to help you successfully the forum really needs pretty detailed infos about everything. Like your hardware, like your environment, etc.

And yes, of course it’s work-intense to gather all these informations. But you might have a running instance in the end. For storing pictures of your cat and everything else (don’t regard NC as being a backup-solution, as it is NOT)

So it’s up to you.

1 Like

Can’t help you with your challenges but came here to say that I’m running NextCloud 19 on a Pi4 using DietPi. Ridiculously easy install and it just works alongside a ton of other apps too. Never had any challenges in keeping it up and stable. It just works.

1 Like

First of all, to answer your initial question: yes, I have NextcloudPi running smoothly on a Raspberry Pi 3 model B. The same Pi also runs Kodi, Transmission, Gerbera and a couple of other bits and bobs. So yes, it can be done!

There are lots of people on this forum that know far more about the inner workings of Nextcloud than I do, and going on the information you posted, they don’t see an obvious reason this isn’t working for you, so I’m not going to figure that out either. My initial install of NextcloudPi went very smoothly, especially compared to the Nextcloud (and Owncloud before that) installation I used to run on an old laptop, so I don’t have any magic extra steps for you. But I’ve spent a good many years tinkering with a number of different Raspberry Pis (and many other devices) trying to get all sorts of projects up and running, and a lot of that time involved banging my head against the wall and yelling “why won’t this just work?!?”. So at least I understand your frustration. The issue usually turned out to be something very basic, but that doesn’t make the process of pin pointing that issue any quicker or easier.

So, based on that experience, my advise to you is to eliminate as many interfering factors as you possibly can. Look at every step you’re taking for granted and think of another way of doing it. Download that .img file again (downloads do go wrong sometimes!) or better yet: try an older version this time (you can always update later).
Try using a different SD card (you don’t want to know how much time I’ve wasted on this one SD card that was only pretending to work correctly…) - your errors mainly seem to be file not found or write permission errors, so that’s definitely something you want to eliminate. Also, try using Win32DiskImager or another alternative to Etcher just to see if it makes a difference - it shouldn’t make any difference, but honestly, some cards just can’t seem to play nice with Etcher or vice versa. If you have another card reader handy, just give it a go.
Don’t bother with the external harddrive during initial setup - just put your data dir on the pi for now and change it later: external HDDs can throw up a lot of permission errors. If it works with the data dir on the card, but not with it on the HDD, you’ve obviously found your problem; if it doesn’t make any difference, you have eliminated one more possible cause and that’s valuable information too. Similarly, don’t bother with external access or encryption - just keep it local during setup and sort all that out once you have things up and running smoothly.

And if all else fails, you can always start out with Raspberry Pi OS (what used to be called Raspbian) or any other Linux flavour, make sure that’s all running smoothly, and then install Nextcloud on top of that. If anything, that’ll help you to eliminate a number of possible causes.

Good luck!


There are many tutorials to install OC or NC on Pi and I started with that couple of years ago and it worked fine for me.
Later I moved to a real PC server which I host on my side running v.18.0.11, the updates goe very well without a glitch, I am not comfortable with virtual installations, I bumped many times into errors and worked it out, we just need to pay attention about all details and learn from our mistakes.

Here is another:

I could have helped you more if I was there but never get discouraged and when it gets on your nerves just leave it for a while then come back to it. Good luck.

1 Like

Mine is stable and has seen several major version upgrades.

If you’re interested in trying a configuration similar to mine, I wrote a guide in it.

1 Like


ls -la /media/myCloudDrive/ncdata

check or confirm if user is correct for the server “user” to your data directory

sudo -u www-data ls -la /media/myCloudDrive/ncdata

if not you need to chown to user www-datat:www-data, use the -R to make command recursive.

sudo chown -R www-datat:www-data /media/myCloudDrive/

sudo chmod -R 0770 /media/myCloudDrive/

1 Like

To answer the first question: Yes, I have NextcloudPi running on a Raspberry Pi 4B 4GB, with data on a USB SSD. It’s stable and has seen many upgrades without problems.

A HDD would normally need its own power supply, the Pi is not able to provide enough power for a HDD. What is your setup?

1 Like

I have Nextcloud running on a Raspberry Pi 4, actually. Manual install. It’s running for months now.
Before that, the Nextcloud instance was running on a Raspberry Pi 2B with 1 GB of RAM. It worked for years. I began with Owncloud, Nextcloud was not forked at that time.
It works without errors.

1 Like