Could not establish connection to the Collabora Online server

I followed this guide to setup Nextcloud + Collabora + Talk.

Collabora is installed but doesn’t connect on office.mydomain.name
I also tried with port 9980 but still no luck :frowning:

My all configuration are same as the guide from above link.

1 Like

The bug in Collabora APP (richdocument) of version 3.6.0. You can try to update it to version 3.7.0, which is just released 22 hours ago.

I reinstalled it and it succeed. :partying_face:

This is still an issue for me. I have updated to 3.7.0 and am using the latest version of CODE. The document server is configured correctly because when I go to that URL I get OK.

I keep receiving this error:
Trying to access array offset on value of type null at /var/www/nextcloud/3rdparty/leafo/scssphp/src/Compiler.php#5230

have the same error and i am on 3.7.0, i had not on 3.6.0

click save: said reach the server

press F5 and the icon said it can reach the server, when collabora is locally installed

We are also seeing the same issue with 3.7.0. The following error is showing in the nextcloud log after attempting to start collabra online:

Error richdocuments GuzzleHttp\Exception\ConnectException: cURL error 28: Operation timed out after 45001 milliseconds with 0 bytes received (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)

for me it worked by rebooting my server
reboot

Same error here… after update to 18.0.5 from 18.0.3 i got the error. Collab server is reachable, but i can’t use in nextcould.

@pravin
I have the same issue and also a reboot doesn’t help.
Did you use the redirection of all http to https during the Let’s Encript installation?

Colabora seems to be started, but it is not reachable in the Nextcloud Settings.
Also I got an Apache default Website if I try to open the FQDN of the colabora server:

I expected a Colabora Welcome Page or something like that. Is this normal, or did something go wrong with the colabora container itself?

1 Like

Ok, nevermind … :see_no_evil:

I did a major mistake at

5.1.Environment Variable

of the guide HowTo: Ubuntu + Docker + Nextcloud + Talk + Collabora

Instead of the public IP, I used 127.0.0.1 for NEXTCLOUD_IPADDRESS variable. After I fixed this, rebuilding the container and rebooting the server, everything is working fine now. :slight_smile:

I installed Nextcloud and Collabora on an Ubuntu 18.04 server following the instructions at: HowTo: Ubuntu + Docker + Nextcloud + Talk + Collabora

When inserting the Collabora server address (office.domain.com) in the Nextcloud settings, I get following error: “Could not establish connection to the Collabora Online server”

Additionally I expected Collabora to show up at my “office.domain.com” website but the Apache welcome-page was there instead.

Installing and enabling the built-in CODE failed as well.

Any hints on how I can solve this issue.

I double checked the config files and repeated the installation already.

@anjo.weichbrodt Please start your own thread and show your Apache and Docker configs. If you’re seeing the Apache default site, then most likely something is wrong with the Apache config.

I opened the developer console and found an error that’s relevant:

Mixed Content: The page at 'https://cloud.domain.com/apps/files/?dir=/Documents&fileid=122' was loaded over HTTPS, but requested an insecure form action 'http://cloud.domain.com/custom_apps/richdocumentscode/proxy.php?req=/loleaflet/ed4f732/loleaflet.html?WOPISrc=https%3A%2F%2Fcloud.domain.com%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F126_ocbttb0r5cs1&title=Welcome%20to%20Nextcloud%20Hub.docx&lang=en&closebutton=1&revisionhistory=1'. This request has been blocked; the content must be served over HTTPS.

(I replaced my domain). Any ideas? I’m using the built-in CODE server and I’m updated to 19.0.2. This seems like a bug.

Did you managed to found any solution? I am also having similar problem.

Nope sorry, I went another route and thus stopped exploring in the direction of nextcloud/collabora for the moment.

That solution didn’t work for me. I tried the standard two-week maintenance routine on the docker parts and it didn’t fix things.

Did you mean you used 127.0.0.1 like this :

docker run -t -d -p 127.0.0.1:9980:9980 -e 'domain=sd\\.fqdn\\.tld' --restart always --cap-add MKNOD collabora/code

I’ve been doing that for many years now and it wasn’t a problem till recently. I’m in the 3.7.11 version of the Collabora Online app.

I carried out the installation exactly according to the following HowTo: Ubuntu + Docker + Nextcloud + Talk + Collabora - :bookmark_tabs: How to - Nextcloud community. This HowTo is using docker-compose and therefore a docker-compose.yml, which has some variables in it. I made the mistake that I have assigned the localhost IP to the variable NEXTCLOUD_IPADDRESS. Thus some port bindings was only set to the localhost ip and external access was not possible.

The NEXTCLOUD_IPADDRESS should be the LAN IP of your reverse proxy.