Collabora Docker container produces zombie processes


#1

Collabora with nextcloud integration works well with me. I have the problem that loolwsd leaves zombie processes behind.
Currently there are 7 zombie processes that from loolwsd as a parent process.
Is there a way to turn it off?


#2

Same here … NC 11 and current Collabora.

17567 ? Ssl 0:34 /usr/bin/loolwsd --version --o:sys_template_path=/opt/lool/s
17575 ? Sl 0:35 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17683 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17684 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17685 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17686 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17687 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17688 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17689 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17690 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17691 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17692 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17693 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17700 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17705 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17715 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17721 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17726 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17732 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17737 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17743 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17774 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17779 ? Sl 0:03 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17788 ? Sl 0:02 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/s
17809 ? Z 0:00 [lo_startmain]
17826 ? Z 0:00 [lo_startmain]
17827 ? Z 0:00 [lo_startmain]
17831 ? Z 0:00 [lo_startmain]
17833 ? Z 0:00 [lo_startmain]
17836 ? Z 0:00 [lo_startmain]
17837 ? Z 0:00 [lo_startmain]
17839 ? Z 0:00 [lo_startmain]
17840 ? Z 0:00 [lo_startmain]
17841 ? Z 0:00 [lo_startmain]
17842 ? Z 0:00 [lo_startmain]
17843 ? Z 0:00 [lo_startmain]
17845 ? Z 0:00 [lo_startmain]
17846 ? Z 0:00 [lo_startmain]
17847 ? Z 0:00 [lo_startmain]
17849 ? Z 0:00 [lo_startmain]
17852 ? Z 0:00 [lo_startmain]
17856 ? Z 0:00 [lo_startmain]
17861 ? Z 0:00 [lo_startmain]
17862 ? Z 0:00 [lo_startmain]
17867 ? Z 0:00 [lo_startmain]
17868 ? Z 0:00 [lo_startmain]


#3

Yep, seeing that as well.
NC11, Ubuntu 16.04.01, Apache


#4

FWIW, This is still happening today, with the most recent Docker image.