[Chrome] problem with sharing contacts

I just tried to share an address book via the contacts app while using the latest Google Chrome (52.0.2743.82) but the share button was not visible.
Using Safari 9.1.2, I had no problems…


For me that is caused by adblock, “disable on this site” doesn’t even help, you need to completly disable it.

Thank you very much!
Adblock really is the problem…

Weird? I wonder which of adblock’s rules this is getting caught by? DO they have a general rule blocking everything with a share icon or “share” in the file name?

Im my case, it was “uBlock Origin” Adblocker in Firefox that prevented (only) the “share icon” of currently unshared calendars to be shown. After whitelisting my NC server, not only the “already shared” calendars could be edited but “unshared” calendars also my be shared (icon is now visible).

Devs/Mods: Isn’t this “Adblocker” issue worth an FAQ entry?

Since this is browser independent, the "[Chrome] " tag of this thread should be removed.
Crosslink: Share a calendar or adressbook is not possible after upgrade

I can’t reproduce the problem using Chrome v53 and uBlock Origin.
It would be interesting to see, which ruleset of uBlock/Adblock blocks the share icon.

If you are using uBlock (Origin), would you mind checking which filter-list is blocking the request?
You can do this via the logger:

I don’t know if this is possible with different ad blocking addons.
@nursoda since you seem to use ublock and having this issue.

1 Like

jfr I opened an issue in the contacts repository on github:

Thanks for reporting the issue @nico @nursoda

After enabling “I am an expert user” in the uBlock Origin Dashboard (click on the dark gray bar at the top of the overlay that appears when you click the uBlock icon), I see that 2 cosmetic rules apply, but need help to pinpoint them.

In Logger, I see no blocked entries (only white ones) upon reloading the page (although it still doesn’t show the icons).

Ah, I think I found it:

When I click the red “.icon-share”, it gets strike-through and a rule is created. Hiiting the “Save” button saves the rule for inspection on the Dashboard. There, I see that now


is blocked. That leads me to the comclusion that the cosmetic rule may be just “@#.icon-share”. This could be solved by using a different CSS tag uncommon on big sites, such as .nextcloud-icon-share.

Does that help?

Bottomline / quickwin / workaround for ordinary user (-> FAQ) is to whitelist the nextcloud domain.

Your findings are a good starting point :+1:.
When you are accessing your contacts/calendar app, click the following icon in ublock:

Afterwards a new tab opens with the following content:

In the second picture you first click on the refresh icon, the reload all requests.
Afterwards you find a red? entry, which is connected to the share icon and click on the text.
This opens 3 and shows, which static filter in which list causes the hiding of the icon.

Edit: Of course refresh the site for the contacts/calendar app and not twitter! :wink: This was just an example.

Played a bit with the available filtering lists in uBlock.

Occurs when using:

  • Fanboy’s Annoyance List (Static filter ##.icon-share)
  • Fanboy’s Social Blocking List (Static filter ##.icon-share)…

I have no red lines in Logger.

It is a yellow line, since it was not occurring for me I was suspecting for it to be red.
By now we won’t “fix” this “issue”, since it is no real issue but rather a fault of the filter lists for using too generic filtering masks. If you want to bypass this problem, simply disable your ad blocking software for your cloud website.

That’s a shame since

  • it will affect many users and
  • is not under control of the admin.

I fully understand that it’s an adblocker issue, however, a fix would be very easy (renaming then share link button css class).