Cant upload files above 245MB

Nextcloud version: 19.0.3
Operating system and version: Centos 8.2.2004 4.18.0-193.19.1.el8_2.x86_64
Apache or nginx version: Httpd (Apache) 2.4.37-21
PHP version : 7.4.10-1

The issue you are facing:
I have an http reverse proxy which nextcloud sits behind. I cannot transfer files larger than 245MB. The webgui pops up and says connection lost, unknown error occured.

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

all from Chrome browser

  1. Select any file 245MB or less and it uploads without issue
  2. Select a file to upload that is above 250MB and it fails

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' =>
  array (
    0 => '',
    1 => '',
    2 => '',
  'trusted_proxies' =>
  array (
    0 => '',
  'datadirectory' => '/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'xxx',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'overwriteprotocol' => 'https',
  'updater.secret' => 'xxx',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____:

In the same file as above

I think this is similar to what im experiencing

But when I add the line:
RequestReadTimeout as stated here:
to my httpd.conf file it complaints its not spelled correctly or something to that effect.

I did notice that the reqtimeout module is in 00-basic.conf, i tried to comment it out but Im thinking the issue is with the proxy because commenting it out didnt solve my problem.

the error log on my nextcloud server is full of these errors:

[Mon Sep 21 21:35:44.324220 2020] [proxy_fcgi:error] [pid 8887:tid 140362198800128] (70008)Partial results are valid but processing is incomplete: [client] AH01075: Error dispatching request to : (reading input brigade)

Any help is appreciated, if you need more info on something, let me know and I will get it as soon as I can. Thank you

Here is my .user.ini

php_value upload_max_filesize 16G
php_value post_max_size 16G
php_value max_input_time 3600
php_value max_execution_time 3600
FcgidMaxRequestLen 13107200

I actually think this may be an issue with my consumer router. If i remember correctly, it doesnt do loopback/redirects from within the network or something (cant enable it). A friend of mine is uploading a 16GB file, so far 1G has been uploaded just fine.

Or your client or browser?

You can also test another server. But i do not know the maximum file size.

Do you use anything like cloudflare, and did you run systemctl reload apache2 after the change?

I’ll have to see about giving that a try

1 Like

I do not use cloudflare or anything like that. All firewalls are off as well, same with selinux for testing.

Ok, did you run systemctl reload apache2 ?

I ran systemctl restart httpd

ok, what is your php config file? cat /etc/php/7.4/apache2/php.ini

mine is at /etc/php.ini

1 Like

I think that upload_max_filesize = 2000G needs to be in MB upload_max_filesize = 200000

oh no kidding? ok, thought G was acceptable according to what I read online. I can change that in a sec.

my friends 16GB upload completed, but he did get an error “Error when assembling chunks, status code 502” which I found this article Error when assembling chunks, status code 504

so I think it has something to do with me if its working for him.

1 Like