Can't connect to Collabora Online :/

Collabora Online: Cannot connect to the host “”.
Please ask your administrator to check the Collabora Online server setting. The exact error message was: cURL error 7: Failed to connect to port 9980: Connection refused

This is the error I’m getting^

I’m not sure what I did wrong, since I followed the instructions exactly as given. I’m using Digital Ocean and the servers run apache.

If you followed the instructions and setup Apache as proxy, you should skip entering the port number in NextCloud.

1 Like

Well now I’m having a new problem - the apply button won’t work :confounded:

1 Like

I’ve the same problem. apply button doesn’t work.

The “Apply” button seems to be very slow and doesn’t give feedback, but it seems that clicking and waiting some time does indeed work. Personally, I also had to use Firefox, since Safari didn’t work.

Here is another solution:

1 Like

I got it (the apply button) to work by disabling the documents app. However, the collabra online app still won’t work. After removing :9980 from the URL (as I am using the reverse proxy as recommended), I get a new error:

Collabora Online unknown error: Client error response [url] [status code] 404 [reason phrase] Not Found is not accessible and delivers a 404, it should deliver something like

So there is pretty certainly a configuration issue in your reverse proxy :wink: – Posting and comparing your configuration with the required one might help.

Sorry for the delay. I have some pressing things to do but I will try to get around to this soon.

<VirtualHost *:443>

SSL configuration, you may want to take the easy route instead and use Lets Encrypt!

SSLEngine on
SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateChainFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on

Encoded slashes need to be allowed

AllowEncodedSlashes On

Container uses a unique non-signed certificate

SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

keep the host

ProxyPreserveHost On

static html, js, images, etc. served from loolwsd

loleaflet is the client part of LibreOffice Online

ProxyPass /loleaflet retry=0
ProxyPassReverse /loleaflet

WOPI discovery URL

ProxyPass /hosting/discovery retry=0
ProxyPassReverse /hosting/discovery

Main websocket

ProxyPass /lool/ws wss://

Admin Console websocket

ProxyPass /lool/adminws wss://

Download as, Fullscreen presentation and Image upload operations

ProxyPass /lool
ProxyPassReverse /lool

This is what I’ve got. I’m stumped as to where I went wrong.

Any idea what could be wrong? I’m thinking of trying it again from scratch.

UPDATE: Resinstalled from scratch, took great pains to follow everything correctly… still getting a 404 error no matter what port I use or don’t use.

I’m stumped and frustrated :frowning:

I have exactly the same error, everything appears correct. If I got to I see the XML with a valid SSL certificate. Yet Like you I get the below error when trying to access from within NextCloud.

Collabora Online unknown error: Client error response [url] [status code] 404 [reason phrase] Not Found
Please contact the “” administrator.

Have you managed to get any further, I’ve tried all sorts for the last week and got nowhere. Do you think it points to the connector app, I tried completely uninstalling the Collabora NextCloud/OwnCloud app and checking the app folder was gone think it was called RichText or something similar then reinstalled but still made no difference.

Hoping you have got further than me or someone else can help us?

Just to add to this, in the NextCloud Log it shows the following whenever I try to access Collabora:

Debug no app in context getDiscovery(): Getting discovery.xml from the cache.

Does this not point to the app not Collabora

i m getting the same issue i have used digitalocean and web installer

I remember something about the need to disable the “files_move” app. Can’t remember for which app, but this freed my “apply” button.


i have install web installer in my domian ,and its woring fine and i have added from apps Collabora Online and when i try to click open any doc i get this massage

Collabora Online: Cannot connect to the host “https://localhost:9980”.
Please ask your administrator to check the Collabora Online server setting. The exact error message was: cURL error 7: Failed to connect to localhost port 9980: Connection refused

I have read on Github at collabora that nextcloud user only set https://office.domain.tld in the required field from nextcloud admin backend. Not the port! (additional settings) Since I do this collabora works but can’t read, or open documents.

I had the issue too with the october collabora-image and self signed certs. Did you upgrade to the november-image? That solved it in my case.

i need help i need step by step setting to install nextcloud in linex ( i know to use web installer in cpanel )
and how to setuo Collabora online in it from basic


download docker
and download collabora and set it up.
look at the nextcloud howto.

then this:

the Ubuntu 16.04 LTS with the Kernel doesn’t support the CONFIG_AUFS_XATTR=y flag I. you need a Kernel from Xenial-proposed (Ubuntu 16.04)you can use Ubuntu 14.04 but you must change the distro name in the following tutorial.

enable Testing repository:

Edit the /etc/sources.list and add this.

deb[distroname] -proposed restricted main multiverse universe

and create this file:

with following content.

Package: *
Pin: release a=[distroname]-proposed
Pin-Priority: 400

make an update and ugrade

sudo apt-get update 

sudo apt-get upgrade 

when download and installation is finished test the kernel Version with

uname -r

it must be:


this Kernel has CONFIG_AUFS_XATTR=y support.

test it with:

grep AUFS_X /boot/config-

(it’s an Ubuntu Bug)

install collabora:

docker pull collabora/code docker run -t -d -p -e 'domain=cloud\\.nextcloud\\.com' --restart always --cap-add MKNOD collabora/code

also install the collabora Nextcloud app
and add only this under settings >> additional settings for collabora:

https://127.0.01 oder https://office.domain.tld

hope it works but without warranty!

other people switched to devicemapper, that worked too.