Can't connect Nextcloud Android app with the server

I just migrated from Owncloud 8.2 to Nextcloud 9.0.52. Everything else (i.e. the web interface, desktop client) seems to work just fine, but I can’t get the Nextcloud Android app to connect with the server. I can enter the URL (no errors), my login and password, but the “Connect” button feels totally unresponsive, it does nothing at all no matter how much I tap it. No error messages are given by the app nor is there anything correlating with the attempts in server logs.

This happens on both my phone (Nexus 5X, Android M) and tablet (Samsung Tab 4, Android L). I also tried the Beta app from F-Droid and the issue is present there too. It’s also present in both my WLAN and when using a direct 3G connection on the phone (so I don’t think the WLAN router’s firewall is the cause either).

The Owncloud app on the same devices still works with the server, although I haven’t tried logging out and re-connecting it.

The server is on shared hosting where I have shell access.

Any suggestions?

1 Like

I confirm this problem!
I have same, but in my case, i tested on NC 9.0.52, on my owner home server, with client 1.0, and the beta client founded on F-Droid, too.
Same result with upgraded NC 9.0.53.

I can connect with WebUI, but not Android Client. Thoses respond me: SSL initialization failed!
Also, the connexion run with Thunderbird on my Debian Sid; i can to synchronize Contact, and Agenda!

My actual server: 9.0.53, with PHP 7.x, powered by Nginx.

Forgot to mention that my installation is served over https too, on Apache. But for me there are no SSL errors to be seen either.

Self-signed certificates?

For me: LetsEncrypt 4096 RSA …

ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_session_cache shared:SSL:10m;
ssl_session_tickets on;
ssl_session_timeout 24h;

ssl_stapling on;
ssl_stapling_verify on;

Another details?

Can you PM me your server address?
Then I can try to debug it.

I attempt, but it appear i can not!

I have got the PM, thank you.
I will investigate and response to you.
But it may take some time, depends how hard to find the cause :wink:

1 Like

No worries, thanks for taking a look at this @tobiasKaminsky!

Quick guess:

It seems that /oc/remote.php/webdav is not correctly accessible AND you are using nginx.
Can you have a look into the solution?

For me, i think that’s not my problem.

About my config nginx is :

location = /.well-known/carddav {
return 301 $scheme://$host/remote.php/dav;
location = /.well-known/caldav {
return 301 $scheme://$host/remote.php/dav;

And i can connect my Thunderbird MUA, on Debian GNU/Linux Sid, and synchronize contact and agenda :wink:

For the hope, i added thoses rules, and after restarting my nginx server:

rewrite ^/caldav(.)$ /remote.php/dav$1 redirect;
rewrite ^/carddav(.
)$ /remote.php/dav$1 redirect;

with same result: SSL initialization failed :cry:

I am relly unsure what the problem is. Can you have a look at

I modified my config nginx:

location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {
    include fastcgi_params;
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $fastcgi_path_info;
    fastcgi_param HTTPS on;
    #Avoid sending the security headers twice
    fastcgi_param modHeadersAvailable true;
    fastcgi_param front_controller_active true;

    fastcgi_param HTTP_AUTHORIZATION $http_authorization if_not_empty;
    fastcgi_param XAUTHORIZATION $http_authorization if_not_empty;

    fastcgi_pass php-handler;
    fastcgi_intercept_errors on;
    fastcgi_request_buffering off;

with same badly result! :frowning:

If i post/publy logs of davdroid, this could be help?

So I did some more digging and turns out this was all due to my having botched the migration. I had used the experimental upgrader script, which kept failing due to timeouts, so I went ahead and tried to finish it up manually. With everything else apart from the Android app working as expected, I was fooled into thinking I had nailed it. But with this issue persisting, I just had to check, and wouldn’t you know, there were still all these files lingering from the previous Owncloud installation that I hadn’t replaced.

Tl;dr; re-downloaded 9.0.52, replaced the existing installation with the files extracted from the download, and the Android app now also connects without issue.

@HucSte, I’m not sure your issue is related, but if you also migrated from Owncloud, you could try re-installing Nextcloud files afresh.

Hi, my first experience is about nextcloud directly: 9.0.52 -> 9.0.53; really, happy for you!

Hello. I have the same problem with NC 9 and the App. It’s run on Apache with Let’s Encrypt.

The Domain.

Thanks for your help. :slight_smile:

Strange, this is working for me with 1.1.0 on an emulator: I tried to add a new account and after entering the server address it shows “secure connection established”.

Oh, sorry. I has forgotten to write. I have forced HTTPS about htaccess. Then the mistake had disappeared.

1 Like

Please, how you do that?