Cannot setup Nextcloud AIO

Hm, is it possible that nextcloud-aio-apache is currently not running?

It was indeed not running. And now it works!! Buuuuuut it’s really slow to load. It loads, eventually, but I don’t think that’s normal, and it still doesn’t explain why I had to disable domain-check.

I think the first load may be a bit slow but additional loads should be faster because caching comes into play then. But this is not an AIO problem, rather a general Nextcloud one.

Also there is this: General recommendations for the best performance · Discussion #1335 · nextcloud/all-in-one · GitHub

This might be related to you specific network infrastructure. E.g. having Cloudflare Proxy in between might already lead to a failing domain validation or it could be related to your router, etc. That is why we offer to skip the domain validation.

No reverse proxy on that one. Basically what I did was just took the arguments the guide outlined for docker and put it like that in the compose file, but for whatever reason it really didn’t like it. I ran the docker container without compose and everything was fine.

Anyway just thought I would throw that out there in case it was something about the compose file. I wasn’t sure if it’s supposed to work that way or not.

hm… then the default docker-compose should have worked out-of-the-box: all-in-one/docker-compose.yml at main · nextcloud/all-in-one · GitHub

Except if you should be using cloudflare or the router is making problems, etc.

BTW, Zoey and me added a few notes on Cloudflare since we slowly get tired of this: GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.

1 Like