Cannot install documentserver_community app - appinfo file cannot be read

Tried to install nextcloud 18 on a new clear system, but getting an error when it tries to install the onlyoffice documentserver app.

Error: App “documentserver_community” cannot be installed because appinfo file cannot be read.

what’s wrong?

thanks

PS: tried it on different systems (ubuntu 18 server)

have you tried installing onlyoffice app as well?

Yeah it worked… i made the automatic install of NC18 and checked “install recommended apps”. After that (and the hint that the documentserver failed to install) i tried it again in the App Manager as admin logged in. And there i’d got that error message.

Thought it could a browser timeout issue… so i tried it again on the shell (console) with the same error message as result

Found a workaround…

Downloaded the app package manually, unpacked it, and moved it into the app folder of nextcloud. Then logged in as admin and activated the app.

Now it works. i think my system has problems to download such huge packages.

Any idea how to handle it for future updates?
Like modifying my PHP configuration?

Maybe this will help you

3 Likes

Yepp, that worked for me. 30s is too short for ~300MB

1 Like

Yeah but i think just changing the timeout isn’t the best solution, for example on low bandwidth connections.

Maybe someone create an issue at github for that?

Thanks

done already

1 Like

Not solving problem here on two NC 18 instances where I have that same problem ! I increased the value of timeout in the client.php file indicated above but it doesn’t look to care as install times out around 30/45s as previously :frowning: Both are some “old” NC instances that have been upgraded in past to NC 16 then 17 and now 18 to get access at the documentserver_community app :wink:

Thanks

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.