Cannot access nextcloudpi in any way

Hello professional helpers :slight_smile:

I’ve got the problem to be unable to connect to the Nextcloud in any way.

I installed the nextcloudpi around 2-3 years ago and a few months back I did the silly thing to disable ncp-web via the web menu.

Got a new Job, didn’t have time to fix this and it ran fine till now.
Today my Nextcloud only says:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

Restarting doesn’t solve the problem.

I tried to ssh to the pi, but it closes the connection right after putting in the user “ncp” and the password. I have read in a thread here, that ncp is not for getting a connection via ssh.

So I took a monitor and a keyboard to the rpi, connected and got the exact same result.

The text says

Now I got no more idea how to fix this…
I don’t know how to log in.

If nothing helps I would try to get my second rpi up running nextcloudpi and try to copy the files.

Hmmm… Wondering about the user ncp in your screenshot. I am using user pi for terminal-access…
(like described in FAQ


(of course with changed password)

1 Like

I tried to get into user pi, too. Either I don’t have the pw anymore (should be the same as user ncp) or it won’t let me. It’s always a “login incorrect”.

I tried Raspberry, too ofc.

1 Like

That was the solution for the first problem. Thank you very much!
Now I have access to the PI via ssh or Web-UI.

In the System Info I see that:

extCloudPi version v1.49.1
NextCloudPi image NextCloudPi_03-28-20
OS Raspbian GNU/Linux 10. 5.10.103-v7l+ (armv7l)
automount yes
USB devices sda
datadir /media/SSD/ncdata (doesn’t exist)
rootfs usage 2.5G/29G
swapfile /var/swap
dbdir /media/SSD/ncdatabase
Nextcloud check error
HTTPD service up
PHP service up
MariaDB service up
Redis service up
HPB service down
Postfix service up
Internet check ok
public IPv4 xxx
public IPv6 xxx
Port check 80 open (ipv4)
Port check 443 open (ipv4)
IP 192.168.178.xx
Gateway 192.168.178.xx
Interface eth0
certificates ***
NAT loopback no
Uptime 7min

The Nextcloud is down, so is the HPB service.

I did some research and found the Datadir is not correct anymore.
Somehow it created a media/SSD1/ in addition to the existing media/SSD/

I looked up the SSD1 and voila, all the datas are in there. I tried to configure it to the correct entry, like described here.
Sadly it won’t let me and after a restart it’s again in media/SSD/
It prompts “/media/SSD1 is not empty”

Any good advices?

Please use ncp-report when posting your system info :pray: or at the very least blur out sensitive information such as your public IP please

Edit your post and remove/blur this info. Since it has been out for a day you can consider it compromised at this point

Edit: I flagged the post so a mod will remove it if they get to the report before you see my response

Thank you for flagging and calling my attention the the sensitive information. I should have known better…


I got the ncp-report without the sensitive data.

NextCloudPi diagnostics

NextCloudPi version  v1.50.0
NextCloudPi image    NextCloudPi_03-28-20
OS                   Raspbian GNU/Linux 10. 5.10.103-v7l+ (armv7l)
automount            yes
USB devices          sda
datadir              /media/SSD/ncdata (doesn't exist)
rootfs usage         2.5G/29G
swapfile             /var/swap
dbdir                /media/SSD/ncdatabase
Nextcloud check      error
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
HPB service          down
Postfix service      up
Internet check       ok
public IP            ***REMOVED SENSITIVE VALUE***
public IP            ***REMOVED SENSITIVE VALUE***
Port check 80        open (ipv4)
Port check 443       open (ipv4)
IP                   ***REMOVED SENSITIVE VALUE***
Interface            eth0
certificates         ***REMOVED SENSITIVE VALUE***
NAT loopback         no
Uptime               13min

Nextcloud configuration

An unhandled exception has been thrown:
Doctrine\DBAL\Exception: Failed to connect to the database: An exception occurred in the driver: SQLSTATE[HY000] [1698] Access denied for user 'ncadmin'@'localhost' in /var/www/nextcloud/lib/private/DB/Connection.php:87
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/src/Connection.php(1519): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/src/Connection.php(1041): Doctrine\DBAL\Connection->getWrappedConnection()
#2 /var/www/nextcloud/lib/private/DB/Connection.php(237): Doctrine\DBAL\Connection->executeQuery('SELECT * FROM `...', Array, Array, NULL)
#3 /var/www/nextcloud/3rdparty/doctrine/dbal/src/Query/QueryBuilder.php(345): OC\DB\Connection->executeQuery('SELECT * FROM `...', Array, Array)
#4 /var/www/nextcloud/lib/private/DB/QueryBuilder/QueryBuilder.php(287): Doctrine\DBAL\Query\QueryBuilder->execute()
#5 /var/www/nextcloud/lib/private/AppConfig.php(361): OC\DB\QueryBuilder\QueryBuilder->execute()
#6 /var/www/nextcloud/lib/private/AppConfig.php(126): OC\AppConfig->loadConfigValues()
#7 /var/www/nextcloud/lib/private/AppConfig.php(317): OC\AppConfig->getApps()
#8 /var/www/nextcloud/lib/private/legacy/OC_App.php(982): OC\AppConfig->getValues(false, 'installed_versi...')
#9 /var/www/nextcloud/lib/private/Server.php(692): OC_App::getAppVersions()
#10 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(160): OC\Server->OC\{closure}(Object(OC\Server))
#11 /var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility\{closure}(Object(Pimple\Container))
#12 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(127): Pimple\Container->offsetGet('OC\\Memcache\\Fac...')
#13 /var/www/nextcloud/lib/private/ServerContainer.php(136): OC\AppFramework\Utility\SimpleContainer->query('OC\\Memcache\\Fac...', false)
#14 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(56): OC\ServerContainer->query('OC\\Memcache\\Fac...')
#15 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(182): OC\AppFramework\Utility\SimpleContainer->get('OC\\Memcache\\Fac...')
#16 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(160): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility\{closure}(Object(OC\Server))
#17 /var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php(114): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility\{closure}(Object(Pimple\Container))
#18 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(127): Pimple\Container->offsetGet('OCP\\ICacheFacto...')
#19 /var/www/nextcloud/lib/private/ServerContainer.php(136): OC\AppFramework\Utility\SimpleContainer->query('OCP\\ICacheFacto...', false)
#20 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(56): OC\ServerContainer->query('OCP\\ICacheFacto...')
#21 /var/www/nextcloud/lib/private/Server.php(1079): OC\AppFramework\Utility\SimpleContainer->get('OCP\\ICacheFacto...')
#22 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(160): OC\Server->OC\{closure}(Object(OC\Server))
#23 /var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility\{closure}(Object(Pimple\Container))
#24 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(127): Pimple\Container->offsetGet('OCP\\Lock\\ILocki...')
#25 /var/www/nextcloud/lib/private/ServerContainer.php(136): OC\AppFramework\Utility\SimpleContainer->query('OCP\\Lock\\ILocki...', false)
#26 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(56): OC\ServerContainer->query('OCP\\Lock\\ILocki...')
#27 /var/www/nextcloud/lib/private/Server.php(2040): OC\AppFramework\Utility\SimpleContainer->get('OCP\\Lock\\ILocki...')
#28 /var/www/nextcloud/lib/private/Files/View.php(118): OC\Server->getLockingProvider()
#29 /var/www/nextcloud/lib/private/Server.php(439): OC\Files\View->__construct()
#30 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(160): OC\Server->OC\{closure}(Object(OC\Server))
#31 /var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility\{closure}(Object(Pimple\Container))
#32 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(127): Pimple\Container->offsetGet('OC\\Files\\Node\\H...')
#33 /var/www/nextcloud/lib/private/ServerContainer.php(136): OC\AppFramework\Utility\SimpleContainer->query('OC\\Files\\Node\\H...', false)
#34 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(56): OC\ServerContainer->query('OC\\Files\\Node\\H...')
#35 /var/www/nextcloud/lib/private/Server.php(1403): OC\AppFramework\Utility\SimpleContainer->get('OC\\Files\\Node\\H...')
#36 /var/www/nextcloud/lib/base.php(594): OC\Server->boot()
#37 /var/www/nextcloud/lib/base.php(1089): OC::init()
#38 /var/www/nextcloud/console.php(48): require_once('/var/www/nextcl...')
#39 /var/www/nextcloud/occ(11): require_once('/var/www/nextcl...')
#40 {main}
HTTPd logs

[Sun Sep 18 10:08:42.358913 2022] [proxy_fcgi:error] [pid 1175:tid 2781078528] (104)Connection reset by peer: [client] AH01075: Error dispatching request to :4443:
[Sun Sep 18 10:08:42.528145 2022] [mpm_event:notice] [pid 1170:tid 3070169664] AH00491: caught SIGTERM, shutting down
[Sun Sep 18 10:09:02.485130 2022] [ssl:warn] [pid 981:tid 3069383232] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name
[Sun Sep 18 10:09:02.534444 2022] [ssl:warn] [pid 1156:tid 3069383232] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name
[Sun Sep 18 10:09:02.540778 2022] [mpm_event:notice] [pid 1156:tid 3069383232] AH00489: Apache/2.4.38 (Raspbian) OpenSSL/1.1.1n configured -- resuming normal operations
[Sun Sep 18 10:09:02.540862 2022] [core:notice] [pid 1156:tid 3069383232] AH00094: Command line: '/usr/sbin/apache2'
[Sun Sep 18 10:11:02.969349 2022] [proxy:error] [pid 1159:tid 2780292096] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.3-fpm.sock (*) failed
[Sun Sep 18 10:11:02.969434 2022] [proxy_fcgi:error] [pid 1159:tid 2780292096] [client] AH01079: failed to make connection to backend: httpd-UDS
[Sun Sep 18 10:11:03.001868 2022] [mpm_event:notice] [pid 1156:tid 3069383232] AH00491: caught SIGTERM, shutting down
[Sun Sep 18 10:11:22.391594 2022] [ssl:warn] [pid 981:tid 3069669952] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name
[Sun Sep 18 10:11:22.426205 2022] [ssl:warn] [pid 1149:tid 3069669952] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name
[Sun Sep 18 10:11:22.432398 2022] [mpm_event:notice] [pid 1149:tid 3069669952] AH00489: Apache/2.4.38 (Raspbian) OpenSSL/1.1.1n configured -- resuming normal operations
[Sun Sep 18 10:11:22.432476 2022] [core:notice] [pid 1149:tid 3069669952] AH00094: Command line: '/usr/sbin/apache2'
[Sun Sep 18 10:54:42.425614 2022] [proxy_fcgi:error] [pid 1154:tid 2763777024] [client] AH01067: Failed to read FastCGI header
[Sun Sep 18 10:54:42.425680 2022] [proxy_fcgi:error] [pid 1154:tid 2763777024] (104)Connection reset by peer: [client] AH01075: Error dispatching request to :4443:
[Sun Sep 18 10:54:42.530818 2022] [mpm_event:notice] [pid 1149:tid 3069669952] AH00491: caught SIGTERM, shutting down
[Sun Sep 25 14:44:53.451320 2022] [ssl:warn] [pid 994:tid 3069809216] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name
[Sun Sep 25 14:44:53.500594 2022] [ssl:warn] [pid 1165:tid 3069809216] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name
[Sun Sep 25 14:44:53.507620 2022] [mpm_event:notice] [pid 1165:tid 3069809216] AH00489: Apache/2.4.38 (Raspbian) OpenSSL/1.1.1n configured -- resuming normal operations
[Sun Sep 25 14:44:53.507718 2022] [core:notice] [pid 1165:tid 3069809216] AH00094: Command line: '/usr/sbin/apache2'

Database logs

2022-09-25 16:36:48 1741 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:48 1742 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:48 1743 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:49 1744 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:49 1745 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:50 1746 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:50 1747 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:51 1748 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:51 1749 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:52 1750 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:53 1751 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:53 1752 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:53 1753 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:54 1754 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:54 1755 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:55 1756 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:56 1757 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:56 1758 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:57 1759 [Warning] Access denied for user 'ncadmin'@'localhost'
2022-09-25 16:36:57 1760 [Warning] Access denied for user 'ncadmin'@'localhost'

Nextcloud logs

tail: cannot open '/media/SSD/ncdata/nextcloud.log' for reading: No such file or directory

I read a bit about the ssd and ssd1 and learned, that ssd should be the controler and ssd1 the first partition. Is that correct?
I integrated the SSD within the first start process of NextcloudPi Wizard and never changed anything.

The second thing is the access denied fĂĽr ncadmin, which seems to be a common problem. I found mulitple threads about it and everyone has another solution. That makes me a bit nervous to to something mytself without breaking it.
I can’t access the /var/www/nextcloud/config/config.php via ssh, because I get a “Permission denied”.

1 Like

Wonderful :pray: it should be okay tho, thankfully residential internet connections usually have a dynamic IP that changes occasionally, so it’ll resolve itself for you when that happens. However it’s still important to know & remember to be careful with your public IP & domain and not disclose them unless you have to. (ex. troubleshooting DNS issues) :slight_smile:

Almost right :partying_face: only a little off

You have for example /dev/sda which could be one drive & then /dev/sda1 which would be one partition on that drive.

View these using the lsblk -a command in a terminal.

The drives can also have something called a LABEL, which is basically like a name tag referring to the drive as a whole and not necessarily it’s various partitions.

I don’t know, for you I think what happened is that your first drive with an existing label of SSD was recognized and another with SSD1 was created.

You’ll have to check & confirm this with the lsblk command though.

Edit: You can also check the mount points in /media/ and move the data over as root or delete the empty one (with prior backups checked &/or done, ofc) and restore it with the one holding the data.

You should also be able to configure it manually in /etc/fstab correcting the references to the correct drive & mountpoint.

This file holds the boot sequence’s mount configurations for your system. Use care here as well

This is normal, if others are looking for the answer to that: This user is created without a /home or $HOME directory and no login shell, it is a system user.

Try with the pi user instead? I think that’s the one iirc :pray: (I use a base Debian Bullseye install with a custom firmware now so I forgot, sorry, it’s in the docs tho)

Same for the config file, except this is owned by the www-data* user, which is the web admin used by apache2 on the system, as a system user

  • (Debian-based Linux distro, others may have different default names for these users. Like Arch, which uses http iirc, I don’t know I might be wrong, writing from memory. It could also be http-admin)

Another edit: it’s http for arch, apache2 for fedora. You can see more examples here

You can always view &/or overcome this by becoming root user, cat /path/to/file to view it in the terminal.

Edit3: (:joy:)
If you are new to Linux, there is one thing you must remember. The root user, always have full control over the system. It’s the root of a tree with all its branches reaching out from there. So be careful about opening access to this user & when executing commands, like removing something, it will just be removed as long the syntax is correct, no prompt and no do-over unless you have a backup. So use care & be mindful of your actions

There’s a doc with common commands in Linux via SSH I think where you can see this :pray: (writing from my mobile :bowing_man:)

Edit2: From your ncp-report it looks like everything is pointing right, but the database couldn’t be found.

I also see you haven’t upgraded to Bullseye in your photo, is that right? :thinking:

Hope that answers your questions? :partying_face:

1 Like

That’s a lot info and a pleasure to read, thanks!
I try to move to Linux completely and for that I did some shell tutorials and installed Manjaro.
So I’m new, but willing to learn :slight_smile:

I looked up the block devices and it’s like that:

cat says this for /etc/fstab
Don’t really know what that means, as far as I read this file should contain all mounted devices. I mean in the first picture we see SSD1 is mounted…

I assume having the previous information, makes the solution to move the data from SSD1 to SSD not that good, right? It’s a device and there shouldn’t be data.
So why can I cd to /media/SSD/ and see ncdatabase with the ls command?
That freaks me out a bit :grimacing:

With this picture it should also be clear that the database cannot be found inside /media/SSD/ because it’s in /media/SSD1/
I could access the config.php with sudo nano. Should I rename there any directory of /media/SSD/ to /media/SSD1/?
I am not sure if this is the right file and the only one I have to edit.

For an ending: No, I didn’t upgrade to Bullseye. I first want to get the data back, make a complete backup and then upgrade. Perhaps I will migrate to my other PI, because 8GB of RAM are not necessary for the nextcloud.
I had some problems regarding big files with the running one. It always freezed if I downloaded a bunch of to many pictures. I think that’s because of 32bit system and I will install the new one with the newer 64bit system.

1 Like

Correct, you shouldn’t move the data in this case, and you can see your label to the right in the picture, under the mountpoint section, like I mentioned for your drive’s mountpoint.

You need to check the PARTUUID for the drive and match it with the ones in fstab.


Alright, in this case you should do this … (hang on)

Do you have another drive, computer or anything you can move your files to?

Do that using the terminal, (rsync over network, copy or move to another drive that’s connected), so they are safe there, verify that they are there.

Then install the new image with Bullseye directly on your external drive with the 64bit OS. Once that’s done, connect and boot the pi using the SD card, go to raspi-config and change the boot order to use an external USB. Save & exit, shutdown and unplug SD card, plugin external drive and boot.

Once that’s done, if you have a backup tar file with your Nextcloud settings you can restore that one now, then move your files back in and scan them with ncc command (use ncc list to see which one), and they will reappear in your restored Nextcloud. If you move your files back in before you’ve restored the backup tar, you will delete your files.

And also, the backup tar includes settings, not your user files. Those are separate, if you only recover the backup and overwrite the drive during install, you will lose your files. Get them out as well

This means they are on different mountpoints, one label per mountpoint and only one of those 2 is currently mounted. The one you can see

Edit: @Robin_Cl I had too many replies in a row so I edited this one instead

Thank you :pray::bowing_man: and also, welcome to the Linux environment & Nextcloudpi community :partying_face:

That’s great, as long as you show a willingness to learn and try to find the answers yourself, then presenting your work with information when asking for help, you’ll be received warmly here by everyone, no matter your skill level.

Not denying it can happen that you get a rude response for different reasons :pray: but a big one is people asking others to do things for them instead of having to do any work themselves, not providing information or not showing the work they’ve done when trying to solve it themselves.

With your attitude, that you are showing your work and have a willingness to learn, this will rarely happen to you though

I see the PARTUUID in blklid.

/dev/mmcblk0p1: LABEL_FATBOOT="boot" LABEL="boot" UUID="4BBD-D3E7" TYPE="vfat" PARTUUID="738a4d67-01"
/dev/mmcblk0p2: LABEL="rootfs" UUID="45e99191-771b-4e12-a526-0779148892cb" TYPE="ext4" PARTUUID="738a4d67-02"
/dev/sda1: LABEL="SSD" UUID="54cb2aea-1a7e-41a5-8452-82c610934a13" UUID_SUB="bf9483c0-aadc-4b5f-a1ad-beb12ef4ae5c" TYPE="btrfs" PARTLABEL="primary" PARTUUID="10849949-68f4-4f99-9786-b39b36572543"

The one SSD I can’t see in fstab and don’t know why. It should list all mounted devices as far as i read.

Before I would try to install the OS directly on the SSD I would try to get it running on an other device.
There seem to be a lot of pitfalls on the way.
I have already backed up my data, but I would like to go step by step without doing anything I don’t quite understand. And there is a lot, starting by how to install an os without wiping the hard drive before, to not knowing if the nextcloud settings would work, I have backed up on the SSD and how to only back up those without data.
To many things I can’t handle :slight_smile:

I would prefer to go with a working nextcloud and migrating to a new one. There should be lot’s of tutorials out there I can learn from.

Is the way re-naming the mounting point in the config.php a good solution or do I crash something? That looks like the easiest way, if that is all I have to do.

Yes, you would do it manually, the /etc/fstab file holds what will be mounted on the system automatically during boot.

Here is the article I used when I first started tinkering with a Raspberry Pi 4, it is the article I learned the basics of how this works with the mountpoints in fstab from when I was manually configuring it to boot from my external drive some year ago :slight_smile:

Perhaps it will be helpful to you as well? :pray: I don’t know

Edit: I had linked the wrong article, sorry :pray: @Robin_Cl

Here’s the correct one

After a long time I have tried to solve the problem again. Unfortunately, I have had little time for it in the last few months.

I recapitulate briefly:
The PI did not find the nextcloud data after a reboot. The reason was that the SSD was suddenly recognized as SSD1.
I could unfortunately never find out why this happened all of a sudden, without me having connected another storage.

I have since managed to rewrite the “datadir” and “dbdir” to SSD1.

datadir = I found in many posts: /var/www/nextcloud/config/config.php
There I had to change all “SSD” to “SSD1”.

dbdir = I found in the following forum entry: NextcloudPi: MariaDB down - can't change path to dbdir
The config-file was located under etc/mysql/mariadb.conf.d/90-ncp.cnf and could be changed with nano without any problems. Using ncp-config it did not work at that time.

EDIT says: You also have to configure the php.ini located at /etc/php/7.3/fpm/php.ini

After a reboot and a few minutes the nextcloud is now running again! Thank you ZendaiOwl and schoetju very much. It took a long time and some things had to settle first, but now it works again.