Can’t download files on phone with Nextcloud app version 3.28.1

Nextcloud version: 28.0.3 hosted on Hetzner StorageShare
Operating system and version: Ubuntu unknown version
Apache or nginx version: nginx/1.25.3 (fpm-fcgi)
PHP version: 8.2.16

Android application
Nextcloud version: 3.28.1

The issue you are facing:

With the latest version of the android application (3.28.1) I can no longer download files on my phone.
I have this issue since several day from a build by fdroid, and have it since today from a build from google play.

Steps to replicate it:

  1. Update to latest nextcloud android version (3.28.1)
  2. Select Download on a file
  3. See the file being downloaded
  4. See there is nothing being written on the storage at the end

There’s already an issue for this on GitHub:

See also here:

Saw this post also WARNING Nextcloud Android client version 3.28.1 deletes user data Revert back to 3.28.0 (F-Droid)

I was redacting my message while it was being posted. Sorry for the noise.

Yep. Not sure if there is really a (big) risk of data loss. But the bug definitely limits the usability of the app. Let’s hope it will get fixed quickly, in the meantime reverting back to 3.28.0 should help as a workaround.

The issue, is that I received this bugged version via Google Play minutes before I wrote here. And I’m not part of the Google Play Beta. So might become more widespread.

  1. In such a situation it specifically should lead to data loss when one client makes a file have zero bytes and that then updates the version on the server and the other clients download the file.
  2. F-Droid users got this right away from the release

widespread and a huge mess up.

Hmm, as I see it, the files are not being downloaded at all, because when I try to download a file via three dots → Download, it isn’t shown as downloaded (no green checkmark) and after I refresh the file list (swipe down) it shows its original size again.

1 Like

Hope this is true in all instances of this bug!
+1 for User Data

I think they are downloaded, tried with a big file, and I could see the progress dialog, but nothing is written at the final place, and the file size is then displayed as 0.
And indeed refreshing the view does show the file still undownloaded, but with it original size.

Maybe it’s also releated to this:

…so maybe the file is created temporarily and then deleted again after a refresh because the download didn’t work or it couldn’t be moved to the actual download location or something along those lines…?

But I’m not a developer and don’t really know the inner workings of the app, so I can’t say for sure what’s happening.

This is insane!
How do I downgrade as a naive user getting the app from google play?

(Ubuntu 29RC2; Android 28.1)

I have the same problem.

Version 3.28.2 has solved the problem. Either you wait until the version is available in the Playstore, or you install the version nextcloud-30280290.apk from GitHub.

This day 7 into the issue by now, family members don’t understand rollbacks. Even though there might be problems just reinitiate the latest working version as 3.28.2 and bring the proper update as 3.28.3

Thats insane.

I don’t understand it either. The new version is still not available in the Google Play Store or on F-Droid.
The fact that it takes so long is really insane. Especially that the app is practically unusable for me.

Hi @DragonDope.
I followed your apk link above and installed that on my android and it works nicely. Thank you for saving me.
This is obviously no solution.

I’m so sad about nextcloud. The documentation and quality control has been consistently poor for me, even though the concept seems one of the coolest things out there.

REVISED: I take that back. it’s still not working for me. Sync doesn’t do anything, and downloading a file gives me an error.

Just hit this today. Now waiting for the update to appear on GPlay, in the meantime the app is practically unusable…

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.