Calendar timezone confusion

I’ve been using owncloud/nextcloud for a few years for personal use, but am now introducing it to a non-profit organization with which I work. So it is only recently that I have noticed the Calendar timezone controversy. I’ve read as many threads and messages as I can find, going back years, regarding the timezone of events, but still don’t understand exactly what’s going on.

The start and end times for any event that I create, whether it be in the web interface or via synchronization from a desktop calendar, shows start and end times on the calendar in UTC.

New events entered into the web interface default to UTC for start/end times. I can change that, although I have to do it individually for both start and end times and for each event (why can’t I have a configurable default for that?). But no matter what timezone I choose, the event shows in the calendar as UTC. The details of the event show the correct timezone, but it displays in the calendar as UTC… so an 8am start (America/Vancouver) shows on the calendar as a 4pm start.

The same thing happens with events created from my synchronized desktop calendar: the event details are correct, but it shows on the calendar with UTC start and end times.

I can set the timezone to none/floating and that “solves” the problem, in that the event details and the calendar display will show the same times, but it’s a hassle to have to change the timezone for every event.

In Oct, 2016, Calendar app developer georgehrke said (Two different times in administration):

Generally speaking the calendar has absolutely nothing to do with the user’s timezone in Nextcloud nor the instance timezone set in the config.php.

The timezone used to display events is always determined when you open the calendar app in your web browser and is not stored on the server.

…but I really have no clue what that means.

I’ve seen references to configuration settings for calendar timezones being deliberately removed from the code, but the explanations for that are too obscure.

Can anyone help me to figure out why I can’t have calendar events display in the calendar with start and end times in the timezone of my choosing?

1 Like

I’m having the same problem… all events are displayed in UTC in the web calender.
Even while creating them marking a time corridor in the web calender there is no problem. But they are always displayed “wrong”…

Short video of the problem…

So in the video I mark the time corridor 7am to 10am and this is saved correctly (my timezone is Berlin as displayed in the event details). But why is the event still displayed as beeing a 6am - 9am event?
When I sync them to my android phones calender they are displayed correctly.

Anyone can help us here? Thanks!

Hi ! I thing this is related to this (browser warning) :

Deprecation warning: use moment.updateLocale(localeName, config) to change an existing locale. moment.defineLocale(localeName, config) should only be used for creating a new locale See http://momentjs.com/guides/#/warnings/define-locale/ for more info.

It seems no issue has been opened yet. That was wrong : https://github.com/nextcloud/calendar/issues/607

Bye :wave:

@tflidd , @georgehrke, any ideas on this?

The start and end times for any event that I create, whether it be in the web interface or via synchronization from a desktop calendar, shows start and end times on the calendar in UTC.

That’s not the intended behavior. Most likely related to the calendar not being able to properly detect your timezone. Although you should see a warning if that’s the case.

But no matter what timezone I choose, the event shows in the calendar as UTC.

Again, not the intended behavior but some bug I honestly never saw before and one that has never been reported to us so far.

but I really have no clue what that means.

They were talking about some timezone issue in another app and i just pointed out, that it’s absolutely not related to the calendar app, because its using its own way to determine a user’s timezone.


@ccsmith @jonaskor Can one of you please create an issue in https://github.com/nextcloud/calendar/issues?
And please use the issue template and provide all the informations asked for.
It’s very important in this case, because I can’t reproduce the issue and I need as many information as possible to be able to reproduce it and help you.

Furthermore please visit the following website and tell us what timezone it shows you: https://pellepim.bitbucket.io/jstz/

Thank you, I will do that!

FYI: On https://pellepim.bitbucket.io/jstz/ the correct timezone is beeing displayed (Europe, Berlin, as correctly saved in my events).
This might be different in @ccsmith case though.

Sorry guys, issue doest seem to be a “calendar app” issue for me. My issue seems to be related to changes I have made in my browser (default firefox/chrome/edge working fine, just firefox with addons/config changes is showing me the wrong time slots…)! Will try to figure out, what change is giving me the trouble… Thanks for your help so far!

1 Like

Hey, I would really appreciate if you could try to isolate the issue and try to find out what’s causing this.
If it’s indeed an add-on, we should reach out to the add-on’s developer and put up a warning in our Readme.

Thx

Hi everyone,

I’ve “fixed” this issue by disabling privacy.resistFingerprinting option in the about:config Firefox panel.
This option blocks the timezone accessibility, and f*cks up JS detection tools.

Hope it’ll help,
Bye :wave:

2 Likes

Thanks Horloge, that worked for me! Nice! Still wondering, why the timezone-detection-website somehow managed to detect my timezone correctly (although not consistently)…

Thanks @Horloge

I will see if we can fix that issue somehow in the calendar.
It would be a real pity if nextcloud didn’t support this crucial privacy option in Firefox

Totally agree, keep me posted. Tell me I you want me to try something out !

I opened an issue in the calendar bug tracker to keep track of progress / new insights: https://github.com/nextcloud/calendar/issues/711

@Horloge Can you please visit https://pellepim.bitbucket.io/jstz/ and tell us what you see?

@jonaskor Can you please verify that the issue is caused by privacy.resistFingerprinting for u?
Unlike u, I’m only seeing UTC when I visit https://pellepim.bitbucket.io/jstz/ instead of Europe/Berlin.

What do you mean by non consistently?

What Firefox versions do you both use?

@georgehrke I was seeing UTC, that’s why I started looking at the browser.
Now, with fingerprinting protection disabled and browser restarted, I see my timezone :wink:

btw, people in the mozilla IRC are recommending disabling that setting because it’s highly experimental
https://mozilla.logbot.info/firefox/20180130#c14213689

Just saying :wink:

I can confirm that setting privacy.resistFingerprinting to ‘false’ shows events in the calendar with times in the proper timezone.

I disabled it in Firefox and the times are correct. In Tor, where resistFingerprinting is enabled by default, the times still show as UTC.

I didn’t know that Tor was enabling resistFingerprinting by default, good to know. So we should do what I suggested in https://github.com/nextcloud/calendar/issues/711#issuecomment-361678711

Implement the manual timezone-chooser and warn users when they are detected as UTC

Just to add my feeble feedback… UTC was being displayed for me, too, and it was on Chrome. After about 5 minutes, it eventually did switch to the correct timezone.