Android client 3.0.2: Auto Upload failing with Connection error


#1

NC v. 13.0.0
FreeBSD 11.1 VM on a FreeBSD 11.1 Host
Apache version 2.4.29
MySQL version 10.1.31
PHP Version: 7.1.13
Android Client: 3.0.2
LG G5 Android 7.0

I just noticed this problem today and I do see pictures uploaded from Feb, 27th, so assume was working two days ago.

Desktop top clients (Windows and ubuntu), Samsung tablet with NC client 3.0.1. The Samsung auto upload pictures after shooting also works.

  • Uninstall/install android client on phone
  • Tested from LAN WiFi and 4G
  • Tested access to web interface from phone and works fine (Only that annoying private key message a bug was open few days ago)
  • Manually uploaded failed photo successful

Apache logs doesn’t show any clue (to me):

[Thu Mar 01 14:12:24.265669 2018] [mpm_prefork:notice] [pid 16561] AH00169: caught SIGTERM, shutting down
[Thu Mar 01 14:15:29.938778 2018] [ssl:warn] [pid 804] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Mar 01 14:15:35.874972 2018] [mpm_prefork:notice] [pid 804] AH00163: Apache/2.4.29 (FreeBSD) OpenSSL/1.0.2k-freebsd PHP/7.1.13 configured – resuming normal operations
[Thu Mar 01 14:15:35.875041 2018] [core:notice] [pid 804] AH00094: Command line: ‘/usr/local/sbin/httpd -D NOHTTPACCEPT’
[Thu Mar 01 14:31:47.548879 2018] [mpm_prefork:notice] [pid 804] AH00169: caught SIGTERM, shutting down
[Thu Mar 01 14:35:09.398852 2018] [ssl:warn] [pid 815] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Mar 01 14:35:09.582259 2018] [mpm_prefork:notice] [pid 815] AH00163: Apache/2.4.29 (FreeBSD) OpenSSL/1.0.2k-freebsd PHP/7.1.13 configured – resuming normal operations
[Thu Mar 01 14:35:09.582297 2018] [core:notice] [pid 815] AH00094: Command line: ‘/usr/local/sbin/httpd -D NOHTTPACCEPT’

I’m attaching the partial log, with entries that shows my phone 4G IP address (correction, couldn’t as didn’t accepted a .txt upload …), so it is here: https://drive.google.com/open?id=1V_8qDfoVzbJ-KMkwm-mqd5q4VUQfZIHq

Any ideas will be appreciated.


#2

I am also seeing this same problem.

Samsung S6 running Android 7.0


#3

me too. oneplus 5 android 8.1


#4

I restarted apache, no change.

I manually uploaded a photo to the InstantUpload/Camera/2018/03 directory and it started working


#5

Same issue with my Oneplus5t.


#6

Manual update works fine, but auto upload won’t.


#7

Reported couple days ago: https://github.com/nextcloud/android/issues/2249


#8

I am having the exact same problem. Has anyone had any luck?


#9

The solution is linked directly above your question. Did you read the issue discussion on GitHub?


#10

Workaround here:


#11

I’m having the same problem with Thema newest android client and NC 13.0.0


#12

Creating subfolders manually solves the problem.
Anyway there’s a fix for the next release