2fa in combination with Card- & CalDav-Sync

Hej there

is it possible to use Card- and CalDav-sync with enabled 2 factor auth? Once I tried it, the sync apps stop working and are asking for new authentication.

Kind regards
//neph

RTFM :wink:

You have to create device passwords.

https://docs.nextcloud.com/server/10/user_manual/session_management.html#managing-devices

If two-factor authentication is enabled for your account, device-specific passwords are the only way to configure clients. The client will deny connections of clients using your login password then.

I got it. :slight_smile: Thank you so much.

Hi, how do you solve it exactly? I tried here with my macbook and created a App-Password - but I got no connection (2fa) with the app Password. Do you have a detailed tip for me? That would be fine. Thanks a lot - uwe

Should work - log into your Nextcloud, create a new app password and use that when setting up the account on your Mac. For setting up the account on your mac you can use the profile that can be downloaded in the settings from nextcloud calendar /contacts app.

Hi Cryx,
thanks for your quick response and help. I tried it again but I get no connection. Without 2fa I know exactly how to setup it. Please take look to my steps - maybe I do one wrong step.

My System:
MacBook Pro MacVersion 10.13.6
Nextcloud Version 19.0.3
CalDav Adress:
https://myservername.de/remote.php/dav/principals/users/MyUserName/

  1. I press new new CalDav-Account on my Mac
  2. Setting up to manually
  3. Go to Nextcloud Calendersettings and copy the (iOS/MacOS) Link. (Not the primary link - correct?)
    -No it will be interesting-
  4. I go to my Nextcloud Settings->Security-> “Geräte&Sitzungen” (I use the German version I think it is “Devices&Sessions”)
  5. Than I go to “Create new App password” There is one question first: What do I type into the box “AppName” is this relevant for the Passwort or do I use there fantasy name or blank?
  6. Than, Nextcloud create’s me an password. And in the box “AppName” the text change to my ‘username’ that I use for nextcloud
  7. I copy the new password and copy it into CalDav Setting Box on my mac paste the password -> and I got no connection. Mac told me username or password is wrong

So which step is wrong or where are my bug :-)? I tried it with both ‘my username’ and the name that I used in the box ‘AppName’. What can I do - and thanks again for your help

greets uwe

The appname is not important and can be anything for you to know which device it is. I have one called macbook and one called Iphone.

Addendum: The username is case sensitive! My mistake!

Same problem with the iOS calendar/contacts.
The generated app password is not accepted.
Does anyone have any more ideas or tips?
Where should I report the bug?? Github?
And what other information is needed?

greets Marcello