25.0.0rc2, 24.0.6rc1, 23.0.10rc1

Bug NC 25RC2 as well as NC 24: Moving an event from one calendar to another does not get propagated to connected clients.
related forum thread: Bug NC25 RC2 (and NC24)
github issue: https://github.com/nextcloud/server/issues/34162

Hi. I just updated from NC 25 beta 6 to NC 25 rc2. After that the albums did not work anymore. They worked for me with 25 beta 6. Now I get “could not fetch albums list” as described here [Bug]: NC 25 Failed to fetch albums lists · Issue #1197 · nextcloud/photos · GitHub

Can anyone confirm this?



After the update to 25.0.0 RC2, I am getting that error with Talk-App, too:

I can´t get my NC to work again :frowning:

[Sun Oct 02 16:16:25.608734 2022] [proxy_fcgi:error] [pid 2832842:tid 140188017727232] [client 78.31.xxx.xxx:x] AH01071: Got error ‘PHP message: PHP Fatal error: Declaration of OCA\Talk\Share\RoomShareProvider::getSharesInFolder($userId, OCP\Files\Folder $node, $reshares): array must be compatible with OCP\Share\IShareProvider::getSharesInFolder($userId, OCP\Files\Folder $node, $reshares, $shallow = true) in /var/www/vhosts/xxx.de/httpdocs/nx/apps/spreed/lib/Share/RoomShareProvider.php on line 520’

The accessibility app was removed and integrated into the server proper.

Can you double-check you have the correct version of Talk for 25?

Good evening,
I installed today the V25 RC2 version (since version, and since then I can’t connect.
The home page shows me “The required configuration value passwordsalt is not configured in your config.php file.”

The passwordsalt =“” in the config.php file, but this was already the case before (I checked in the saved folders).

If this is useful :
PHP 8.1.11
arch linux 5.19.12-arch1-1

The nextcloud logs remain empty and I see nothing in the apache logs

A post was split to a new topic: No file structure are displayed after updating to 25.0.0rc2

@eehmke - Sorry, that still doesn’t work for me. Hmmm…

Did you consider looking through past pasting of this error on the forum and Github? afaik, you have previously enabled and then disabled the server encryption module.

Search results for 'Invalid private key for encryption app. Please update your private key password in your personal settings to recover access to your encrypted files' - Nextcloud community.

@just - I restored a backup of my system that was made prior to this error condition so I am good now. However, I don’t recall ever selecting anything to be encrypted, so I don’t know what any encryption key would ever be needed for my installation.

1 Like

Hi all im working on updating from RC2 to RC3 and im still getting this. HAs this been fixed ?


1 Like

Clearly not fixed, at least for you.

1 Like

I think it should be fixed for RC4.

1 Like

Additional you need to delete the .step file in the data folder. Just did this today to upgrade from RC1 to RC2.

@AndyXheli - are you by any chance using PHP 8.1? I am and I’m getting the same error as you. I’m also seeing some odd messages in the nextcloud.log file about deprecated event type?

Did you check your errors and odd messages against those reported to the nextcloud server github repo?

Hey @Alexander_Robinson1 no im running
PHP 8.0.24 (cli) (built: Sep 29 2022 22:26:48) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.24, Copyright (c) Zend Technologies
with Zend OPcache v8.0.24, Copyright (c), by Zend Technologies

There’s an open issue on github [Bug]: NC 25 error when trying upgrade from beta 7 to RC1 with GUI · Issue #34201 · nextcloud/server · GitHub

so if anyone is having issues please make your updates there.

Apologies all, but I am rather confused by this:
a) I cannot find the value in the admin screen anywhere but of course I can run the code any I get:
Insert as “updater.secret”: something _really_long
The plaintext value is: something_else_really_long
b) I then edit the config/config.php file and overwrite update.secret with something_really_long
c) then restart apache2 and php8.1-fpm
d) do I then either
i] enter my password or something_different into web update screen
ii] restart the webupdate process, i.e. go back to the previous screen

also I cannot find any .step file

how do I best proceed ?

thank you

I use php8.1 and the server side encryption app has not been enabled

@John30k did yout try that : " Instead of clicking that button you can now invoke the command line based updater by going into the updater/ directory in the Nextcloud directory and executing the updater.phar as the web server user. (i.e. sudo -u www-data php /var/www/nextcloud/updater/updater.phar)"
from Upgrade via built-in updater — Nextcloud latest Administration Manual latest documentation

works fine for me.

yip thanks, I tried that about 30 minutes ago :grinning:

@thierry1 - thanks! The manual update command worked for me.