12.0.5 and 11.0.7 are out - time to upgrade!


#22

Hi,

Thank you very much!

I had a look into the database, but was not sure which table actually stores the contacts. A select on oc_cards and I get a lot of this:


yE9BQA19MjPO0UARnTYyOgoDXuN/stPQUBr3E/stPb86B3Yf2Wnt+dAXYo0tM9BQLXuO/syP0F
AD10+PptFAEi6fGoPAzQA5bRVHQUAL9mHolADlh2joKAF8tvQUALg+1AC7KAECEGgB9ABQAUAF
ABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQA
UAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFA
BQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAU
AFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAB5FADNh9qADYfagA2H2oANh9qADYfagA2H2oAA
hBoAfQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFA
BQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAU
AFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFAB
QAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUA
FABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQ
AUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAF
ABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQA
UAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFA
BQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAU
AFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFABQAUAFAB
QAUAFABQAUAFABQAUAf/2Q==

Then, for users on my server:

BEGIN:VCARD
VERSION:3.0
PRODID:-//Sabre//Sabre VObject 4.1.2//EN
UID:[UID]
FN:[UID]
N:[UID];;;;
EMAIL;TYPE=OTHER:[USERY-MAIL]
CLOUD:userY@server-domain.tld
END:VCARD

And very much of this:
±----±--------------±------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


#23

@Schmu: lets move to private messages, … I’m not sure if posting about this specific Problem in this thread is rigth.


#24

Got several bugs in IE11! Will try to make issues this week.


#25

For me update worked like a charm (Server: Ubuntu, Clients: macOS, iOS, Ubuntu)


#26

Works fine with PHP 7.1.13 (from remi) at the latest CentOS 7.


#28

I am currently on 11.0.6 with production channel. But updater tells me to upgrade to 12.0.5. (also tested with stable channel makes no difference) is the update to 11.0.7 only supported via manual?


#29

Does 12.0.5 require Php 7+ ?

I’m still looking for a reliable way to upgrade from 12.0.4 safely. I have nearly lost the whole thing twice by following the instructions in the documents or web updater.

What is the best way to do incremental upgrades? And then not lose the encrypted data?

Thanks


#30

according to this, no.
https://docs.nextcloud.com/server/12/admin_manual/installation/system_requirements.html

but php7.0 is recommended.


#31

Update from 12.0.4 to 12.0.5 with the web updater worked absolutely fine with me (server on Ubuntu 16.04.3 LTS migrated from oC, Clients Ubuntu desktop and Android).


#32

are there blocking issues for nextcloud box?
still on 12.0.4…


#33

Installed NextcloudPI (Nextcloud on Raspberry PI) for the first time 2 weeks before 12.0.5. Upgrade from 12.0.4 to 12.0.5 went flawlessly.


#34