You have no permission to write to the selected folder!

I try to synchronize a share of a Samba Server (Debian Buster) with my windows Client (Windows 8.1, Nextcloud client 3.3.5) to my selfhosted Nextcloud. The share is assigned to L:
Adding the share is not possible, the message of the nextlcour windows client is: “You have no permission to write to the selected folder!” (German: “Sie haben keine Schreibberechtigung für den ausgewählten Ordner!”), but this is wrong. The local windows user have all rights on the Windows share.
Other shares of the same samba server works fine.

Does it work for other drives like “C”?
What kind of drive is “L”?

As written above L: is a letter assigned to a samba share of my debian buster system. Trying \\servername\share didn’t work also. Other Drives (also samba shares of the same Server) can be shared. Is there a way to remove all shares saved in the registry from former Nextcloud client versions?

I am little confused.

Do you have a NC server and you are using the NC client to sync to a mounted drive letter?

Or do you have a samba share mounted to your NC server and try to sync to a local drive “L”?

Please answer.

I have a self hosted external nextcloud server (in a datacenter) and a local fileserver (with windows shares) in my homeoffice. I sync files from my LAN to my NextCloud.
And yes, it works for other drives like C. I sync some other drives from the same local fileserver to nextcloud.

Is it NTFS, FAT32 or DFS, or other type?
Obviously the client got no write permission when asking the OS for permission.

It is a share! The Filesystem of the Samba Server is irrelevant. It is the job of Samba to transfer the Linux Filesystem settings of the ext3 drive to Windows Settings - and Samba does this job well. So the User, which is starting the windows nextcloud client, have the rights to create, to modify, to delete files and directories in the share.
Only the Nextcloud Sync app goes wrong.

I try to help you and there are so many setups out.

Please check the nc client log for details.

I have not seen any logfile-links in the nc client app. Searching for log files i found this information on
“To obtain the client log file:
Open the Nextcloud Desktop Client.
Press F12 on your keyboard.”
Tried a little bit and seen, that it is not enough to open the “Hauptfenster”. After opening the settings-Window i could reach the logfile activation. But there are no log entries in the log destination after trying to add the L:\share as sync source. Other letters like I:, Q: and R: works fine on the same machine.


Are I, Q and R drives are different to L?

Hi @RalphGL

Does your Windows user have write permissions on drive L? Or in other words: Can you create folders and files on this share directly via Windows Explorer? If not, the permissions on the SAMBA server are not set correctly…

In other words:
On the server in /etc/samba/smb.conf the share “Steuer” must contain the entry “ReadOnly = No” and perhaps a valid “Create Mask” - value.

Yep. But I don’t think it’s a permisson issue anymore. I tested this briefly on my Win10 machine and had the same exact issue. I have no idea what caused the issue, but after I unmounted the share and mounted it to another drive letter it worked. Then I changed it back to the original drive letter and it worked again. Btw… I deleted the account each time in the app and added it again after changing the drive letters…

@RalphGL Maybe this will help you somehow, although as I said I have no idea what exactly causes this issue…

this are different shares from the same samba server

As i have written above:


This is really strange.

I have tried to add a second share to a drive q:\othersubdirectorythansharedbefore and this was not possible. So the problem must be caused by a newer version of nextcloud. The old shares which was created one or two years ago ares still working. New shares are not possible.

I would like to reset all share-settings for this server and create them new. but uninstalling of the windows client does not help. After uninstalling and a new install the same (old) shares are there again. I think there must be some garbage - created from a prior version of the windows client. How can i remote this. A “purge” which removes all settings of the nextcloud windows client on the windows system would be fine.

Remove folder %APPDATA%\Nextcloud to remove all settings.


1 Like

I just ran into the same problem using the current Windows Client (3.3.5 and a previos version; 3.3.x I guess): A folder located on a NAS/SMB/Samba share which is mapped to a local drive should be shared to a nextcloud instance. Windows itself can access the folder fine for reading and writing, however nextcloud reported missing write permission. The same configuration worked with previous versions. The problem also appears for SMB-Shares using different servers like Windows Server 2016, so the problem is most likely related to SMB itself, not Samba or Unix File Permissions. Deleting APPDATA%\Nextcloud did not help. Folders on local drives work fine. I hadn’t had the chance to test when this regression was introduced due to the need for reboots between downgrades, guell I’ll take a look at that in the following days.

Meanwhile I have installed the Nextcloud Desktop Client v. 3.3.5 on a Windows 10 and a new Windows 11 System.
Syncing samba shares is no more possible on this system too (and yes, all shares are writeable for the client user).