You are currently running PHP 7.0.33-0+deb9u3. Upgrade your PHP version

#1

Hi All
I use Nextcloud 15.0.5 and one reports

You are currently running PHP 7.0.33-0+deb9u3. Upgrade your PHP version to take advantage of performance and security updates provided by the PHP Group as soon as your distribution supports it.
Please double check the installation guides ↗, and check for any errors or warnings in the log.

I updated php to 7.3
php -v

`PHP 7.3.3-1+0~20190307202245.32+stretch~1.gbp32ebb2 (cli) (built: Mar  7 2019 20:22:46) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.3, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.3-1+0~20190307202245.32+stretch~1.gbp32ebb2, Copyright (c) 1999-2018, by Zend Technologies`

systemctl restart apache2

And still shows me that I have php 7.0.33 …
Where could the problem be?

#2

Please check that your webserver is using the same php version as you cli does.

Search the web about your webserver and how to configure php for it.

#3

Disable old php version with:
a2dismod php7.0

Enable new php version with:
a2enmod php7.3

and restart apache2 service…

#4

If I’m enable php 7.3 then nextcloud not work

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.
#5

Check the webserver error log and you will find the cause.

#6

OK repaired

#7

Hello @gusto.

Please explain how you fixed it. The information is useful for all other users.

#8

I uninstalled all old php versions (7.0, 7.1, 7.2) and Installed php 7.3

1 Like
#9

I’ll just add that in my case (Nextcloud 15 on Synology NAS) I had to go to Synology -> Web Station -> General Settings and selecting Apache 2.4, php 7.2 and Apply. Restarted.