XU4 with EMMC - Move Data Dir to External Hard Drive - Permission Issues

I feel like I have tried everything to get my external hard drives (loaded with existing data) to work.

I have even tried a freshly formatted (in ext4) 16gb flash drive with no luck.

I enabled auto mount for the flash drive and tried to use the [ nc-datadir ] tool from the NextCloudPi Web interface to move the data directory. I usually get this error:

Error reading data directory. Is NextCloud running and configured?

Depending on who I make the owner of the drive, I can get these types of errors:

{“reqId”:“tqGY3vt0fleu4vZ8Wghx”,“level”:3,“time”:“2018-07-13T14:09:32+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"–",“url”:"–",“message”:“file_get_contents(/media/USBHDD1/ncdata/news/config/config.ini): failed to open stream: No such file or directory at /var/www/nextcloud/lib/private/Files/Storage/Local.php#214”,“userAgent”:"–",“version”:“13.0.4.0”}
{“reqId”:“tqGY3vt0fleu4vZ8Wghx”,“level”:2,“time”:“2018-07-13T14:09:32+00:00”,“remoteAddr”:"",“user”:"–",“app”:“news”,“method”:"–",“url”:"–",“message”:“Configuration invalid. Ignoring values.”,“userAgent”:"–",“version”:“13.0.4.0”}
{“reqId”:“tqGY3vt0fleu4vZ8Wghx”,“level”:3,“time”:“2018-07-13T14:09:32+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"–",“url”:"–",“message”:“mkdir(): Permission denied at /var/www/nextcloud/apps/news/lib/AppInfo/Application.php#143”,“userAgent”:"–",“version”:“13.0.4.0”}
{“reqId”:“tqGY3vt0fleu4vZ8Wghx”,“level”:3,“time”:“2018-07-13T14:09:32+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"–",“url”:"–",“message”:“fopen(/media/USBdrive/ncdata/nextcloud.log): failed to open stream: Permission denied at /var/www/nextcloud/lib/private/Log/File.php#135”,“userAgent”:"–",“version”:“13.0.4.0”}
Error reading data directory. Is NextCloud running and configured?

The last error comes when the owner of everything is ncp. I have tried root as well as www-data for everything, all with permissions of 0777.

I have also tried to use the nc-format-USB tool, but with the emmc module I get this error:

ERROR: counted 4 devices. Please, only plug in the USB drive you want to format

Not sure I am unable to unmount anything else? I installed the image for XU4 and HC1.

Before giving up on the External Drives, I even manually set the exec flag in fstab, but that did nothing.

Any thoughts on what else I can try?

If anyone finds this later, I was able to work around all of it by booting nextcloud pi off an SD card and formatting my drives one at a time.