Write permission issues when updating from 10.0.1 to 10.0.2

I just tried upgrading an existing nextCloud 10.0.1 instance to the latest version 10.0.2 using the new updater.

Unfortunately, the Check for write permissions step gives me the error The following places can not be written to: followed by a very long list of files.

All those files are within the directory /var/www/web/nextcloud/updater/ which right now only holds 1 file (index.php).

Here’s a screenshot of the currently set permissions which look correct to me:

I’m running the nextCloud installation on Ubuntu 16.04 LTS with PHP 7.0.8 installed.
Please let me know if I can provide you any more information.

Thanks & best regards

2 Likes

I believe the updater overwrites almost everything in the NC root as the www-data user, yet basically all of that is owned by root with no R/W for the www-data group.

What are some of the files it suggests can’t be written out of interest?

As far as I can see it only mentions files within the updater folder, none from the root directory:

Maybe it’s because the mentioned files don’t exist in the updater folder?

@nickvergessen @LukasReschke

I guess this is related…

1 Like

Same problem here, but the list of files is very short

/var/www/nextcloud/updater/ is owned by www:data ,Permissions 0755
and includes only index.php

Edit: Ubuntu Linux 16.04.1, PHP 7.0.8

Edit2: sudo chown -R www-data:www-data /var/www/nextcloud
solved the problem…

4 Likes

I have the same problem updating 10.0.1 to 10.0.2

Check for write permissions
The following places can not be written to:

    /var/www/nextcloud/html/updater/../.
    /var/www/nextcloud/html/updater/../.htaccess

The only file inside …/updater is index.php
The owner of the whole structure is www-data:www-data rw-r-r

Hi, guys!
Same trouble:


Looks like all permissions are done. Where i’m get mistake?

I think the webroot must be chown -R www-data:www-data nextcloud_dir
I will check tomorrow morning to see the history how I resolved it

I had. almost, the same problem and checked my history, it was fixed with chown -R www-data:www-data nextcloud_web_dir (-R) in case something into there was root:root

5 Likes

Shot man that worked! thanks a mil!

this also worked for me - many thanks. any reason why this is happening and needed? Will it be needed again for future upgrades? I don’t recall doing anything in particular on my install to change permissions of files.

1 Like

I had exactly the same problem when I went to update from 11.0.1 to 11.0.2 ( apache2 ).
Me too solved the problem of permissions, executing :
sudo shown -R www-data:www-data /var/www/Nextcloud_Dir
but it is the right way ?

The right is to follow these permissions , correctly ?

A similar chown fix is outlined here: https://docs.nextcloud.com/server/11/admin_manual/maintenance/manual_upgrade.html

chown -R www-data:www-data

def worked for me

Worked for me too… Thank you very much

Hi, I know this is old post, but it was still on first google page in my lookup for v12->v13 update, so I decided to give a hint for people that couldn’t make Updater going with chown and chmod commands.

I had Nextcloud installation on Fedora server in folder outside of primary Apache folder, so any permission I used, even 777 apache:apache on everything didn’t work, because SELinux was blocking writing. If this is your case, use:

sudo chcon -R -t httpd_sys_rw_content_t /path/to/your/nextcloud/folder

See: this and then this.

1 Like

Thanks you very much, your solution still works on update 13.0.4 -> 13.0.5

Thank you for guiding but It still had same problem when I update from 17.02 to 18.01 (I had use: # chown -R apache:apache /var/www/html/nextcloud)

Please help!

  • Initializing

Current version is 17.0.2.
Update to Nextcloud 18.0.1 available. (channel: “stable”)
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-18.0.1.zip
Open changelog :arrow_upper_right:
Retry update

  • Check for expected files

  • Check for write permissions

The following places can not be written to:

  • /var/www/html/nextcloud/updater/…/console.php
  • /var/www/html/nextcloud/updater/…/version.php
  • /var/www/html/nextcloud/updater/…/COPYING
  • /var/www/html/nextcloud/updater/…/AUTHORS
  • /var/www/html/nextcloud/updater/…/index.php
  • /var/www/html/nextcloud/updater/…/status.php
  • /var/www/html/nextcloud/updater/…/robots.txt
  • /var/www/html/nextcloud/updater/…/occ
  • /var/www/html/nextcloud/updater/…/remote.php
  • /var/www/html/nextcloud/updater/…/cron.php
  • /var/www/html/nextcloud/updater/…/index.html
  • /var/www/html/nextcloud/updater/…/public.php

I have the same issue @Rdot-idps (same set of written places refused as well) trying to figure it out now. Did you have any luck?

Update: Fixed the initial issue: run this script here:
https://docs.nextcloud.com/server/9/admin_manual/installation/installation_wizard.html#setting-strong-directory-permissions

Fixed this!

Update 2: That script does not fix an issue, it adds another one. This issue is an SELinux issue (I’m on Fedora 32). I’ve played around with the SELinux settings for a few hours but they’re just a royal pain in the rear end. Disable SELInux, run the web updater, and then re-enable it.

I wrote a more detailed fix here: